Plymouth Theme don't work during shutdown

Asked by Massimo on 2019-04-10

currently I use Ubuntu 18.04 on a dated, but valid Thinkpad X201.

From the WebSite:

https://www.gnome-look.org/p/1281879/

I decide to download this “Plymouth theme” and faithfully follow the instructions for its installation. Everything works properly, written, resolution etc… but when I log out of the system, either with "Turn Off" or "Restart" the exit screen of the chosen Plymouth-theme, does not appear. In the sense that if the active theme at that time includes a writing or an animation and I expect it to show up also during the shutdown of the OS.
When I logout I simply see a black screen and the system closes regularly.
I also specify that the theme in question provides an animation at boot time - which I see regularly - and a different one at logout.
Obviously I tried other themes and also the default theme (which I didn't delete) but this "small" malfunction remains.

Some idea ?

Below I write the output of some commands:

@ThinkPad:~$ lspci | grep -E 'VGA|Display|3D'
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)

@ThinkPad:~$ sudo lshw -c display | grep driver
configuration: driver=i915 latency=0

this is the file of my Grub:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT="0"
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT="1"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE="960x600"
# cartella per sfondi Grub ##
#GRUB_BACKGROUND="/usr/share/GrubImages/Grub01-960x600.png"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID="true"

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

#GRUB_FONT="/boot/grub/unicode.pf2"

What can I do to see the theme during shutdown?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu plymouth Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:

Have you contacted the author of the theme?

I've seen the opposite way around with Nvidia drivers but you are using an Intel GPU.....

Massimo (max-1960ufo) said : #3

Yes, I contacted the author. I have not received a solution. For the drivers I have already seen ALL open source solutions to update. But I didn't have any changes.

Can you help with this problem?

Provide an answer of your own, or ask Massimo for more information if necessary.

To post a message you must log in.