plymouth shows boxes for font in oneiric

Asked by Jari

At boot the plymouth splash screen shows only boxes for characters. This is after the grub menu. I have an encrypted volume so the splash screen shows up with a password prompt (and the ubuntu logo) and a success message afterwards. At least that's what the messages used to be in Natty. I recently did two successive upgrades, from Maverick to Natty and Natty to Oneiric and that's when this started.

I have tried reinstalling ttf-dejavu-core as someone had trouble with that and tried also upgrading to the latest plymouth but it does not help. I booted with plymouth:debug but the Plymouth debug log does not say anything about fonts. When I test Plymouth in X11 the fonts display ok.
Any ideas?

Question information

English Edit question
Ubuntu plymouth Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Jari (jam-1) said :

Almost two weeks have passed and no-one has been able to help. :-(
Would anyone have ideas as to if reinstalling some packages could help? As an inexperienced Ubuntu user I have not dared to experiment with removing/installing things partly because I have had some trouble in the past due to the encrypted volume.
Or is there anyone out there who knows how the font gets selected (or if this is at all font related)? My Ubuntu installation is in Finnish language but that brings no special font requirements.

Revision history for this message
delance (olivier-delance) said :
Revision history for this message
Launchpad Janitor (janitor) said :

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Revision history for this message
Jari (jam-1) said :

Reopening to give the answer

Revision history for this message
Jari (jam-1) said :

I managed to solve this so I thought I'd post the solution here in case someone finds it useful.

After giving the volume password and pressing Esc to see a terminal screen I noticed the following error messages:
 (process:300): Pango-CRITICAL **: No modules found:
 No builtin or dynamically loaded modules were found.
 PangoFc will not work correctly.
 This probably means there was an error in the creation of:
 You should create this file by running:
  pango-querymodules > '/etc/pango/pango.modules'

 (process:300): Pango-WARNING **: failed to choose a font, expect ugly output, engine-type='PangoRenderFc', script='latin'

 (process:300): Pango-WARNING **: failed to choose a font, expect ugly output, engine-type='PangoRenderFc', script='common'

That lead me to lookfor Pango related issues.

For some reason I had /usr/lib/pango as a symbolic link to /usr/lib/i386-linux-gnu/pango which lead Plymouth to point to wrong (old) location for Pango and the fonts were not copied to initramfs.

Removing this link and running "sudo update-initramfs -u" solved the issue.