Plymouth Splash Screen in 10.04 shows only on Shut Down

Asked by James Loveitt on 2010-04-28

So I just switched to 10.04 which is looking good - the only thing that didn't really work after installation was the splash logo on boot, with the red dots...

When shutting down the logo with the dots shows up, and works fine. I have had a play with grub and adjusted boot splash settings and stuff, but made no difference. I don't want to make a royal mess out of everything without asking around first.


P.S. - One other little annoyance - when I change themes, the buttons for minimize, max and close all return to the new 10.04 left orientation and I have to go and rework them... Is there a fix for this little foible too?

Question information

English Edit question
Ubuntu plymouth Edit question
No assignee Edit question
Last query:
Last reply:
James Loveitt (pilot-james) said : #1

By the way, after the BIOS, the only thing it shows before the password prompt for Ubuntu is a white blinking cursor in the top left... No purple background, nothing like what I've seen on other peoples machines.

Marc Stewart (marc.stewart) said : #2

TIP: You should ask separate questions as separate questions, rather than PS-ing them onto the end of unrelated ones, if you want to increase your chances of getting a useful answer.

I can't suggest any technical fixes, but I've also noticed that problem with Plymouth (which actually has orange dots) a couple of times. Fortunately it's always fixed after the next update. Potentially patronising question, I know, but have you run the Update Manager to be sure you're using the latest version?

James Loveitt (pilot-james) said : #3

Note taken regarding the separation of questions... I'm used to laying everything out in one so that people don't complain of overposting, etc.

I ran update manager this morning, nothing pertained to Plymouth. Maybe I'll try a re-install of all the plymouth related stuff via synaptic...

A quick websearch reveals this:

Please at least websearch a little before asking questions, it really makes thnigs happen faster :)

Log a bug with plymouth is all I can recommend. Lucid is still very buggy and unreleased, there will also be lots of bugs after release due to Canonical's rigid release schedule.

GREG T. (ubuntuer) said : #5

i do not think the splash screen is a problem . after the last up dates my my start up time is around 20 seconds .my system is set to auto login . the splash screen is just , well just a flash then my desktop starts.
my system is a compaq with an amd 4000+ 2 gb ram and 120 gb sata hdd . with ubuntu 10.04 . with 9.10 my time was 1min 30 seconds.
 and for the buttons after a bit you get to liken them on the left side

If you are happy then mark as solved.

James Loveitt (pilot-james) said : #7

No offense... but I did do some "websearch" and nobody really had complained about the lack of a splashscreen like I experienced - nor said that their window buttons return to the left with every subsequent change of a theme. I do understand that Lucid will be buggy for a little while but I thought these forums were for people to post potential widespread problems??? Soo, yes, I am happy, but my problem(s) is/are not resolved.

Steven Sauls (ssauls1967) said : #8

I filed a bug as this also affects me with a clean installation. The bug # is 573753. However, no one is responding.

Steven Sauls (ssauls1967) said : #9


Steven Sauls (ssauls1967) said : #10

Still no splash screen on boot except for just about 2 seconds and then it is stretched out in the wrong resolution.

Can you give the output of:

sudo lshw -C display

If you have an nvidia card I have some gold for you :D

Steven Sauls (ssauls1967) said : #12

       description: VGA compatible controller
       product: C51 [Geforce Go 6150]
       vendor: nVidia Corporation
       physical id: 5
       bus info: pci@0000:00:05.0
       version: a2
       width: 64 bits
       clock: 66MHz
       capabilities: pm msi bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:18 memory:b2000000-b2ffffff memory:c0000000-cfffffff(prefetchable) memory:b1000000-b1ffffff memory:80000000-8001ffff(prefetchable)

Dude you totally have the same thing I had. Use this:

Off to bed now, I'll read your thanks in the morning :D

Steven Sauls (ssauls1967) said : #14

Still a no go for me. I still got a black screen on boot and lost my sound.
I reversed all of the commands and got the sound back and got the 1/2 second ubuntu logo in 640x480 back.
I guess I just wait for the fix to come down through the updates.
I filed a bug report on it.

James Loveitt (pilot-james) said : #15

Yah, still a no go for me too - but, I have a feeling that boot is so quick now, that there is no time for the splash to even load!?!?!

Hey James,

 try install a plymouth theme for your boot screen that should get the black screen off. I'm trying to get the black screen back and trying to remove the plymouth themes with no luck.

Try this hope it helps, worked great for me.

Hey James,

 try install a plymouth theme for your boot screen that should get the black screen off. I'm trying to get the black screen back and trying to remove the plymouth themes with no luck.

Try this hope it helps, worked great for me.

Can you help with this problem?

Provide an answer of your own, or ask James Loveitt for more information if necessary.

To post a message you must log in.