no shutdown or reboot option (kubuntu 20.04)

Asked by Willem Hobers on 2020-05-20

I am possibly missing something obvious but when I open the main menu (locale Dutch) and click Leave (if that's the english term used) then I have the options "Lock", "Log off", "Change user" and "suspend to RAM", but no "shut down" of "reboot".

If I do sudo reboot, or shutdown now it works without problem.

What must I do/change to get reboot/shutdown options visible in the menu?

Operating System: Kubuntu 20.04
KDE Plasma Version: 5.18.4
KDE Frameworks Version: 5.68.0
Qt Version: 5.12.8
Kernel Version: 5.4.0-29-generic
OS Type: 64-bit
Processors: 8 × Intel® Core™ i5-8250U CPU @ 1.60GHz
Memory: 3,7 GiB

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu plasma-desktop Edit question
Assignee:
No assignee Edit question
Solved by:
Bernard Stafford
Solved:
2020-05-28
Last query:
2020-05-28
Last reply:
2020-05-28

If you change language to English is it OK?

Willem Hobers (whobers) said : #2

It seems I can't change the language.

If went to system settings --> Personalisation --> Language. The value there was US (default). [Not Dutch....]. When I clicked Add Languages the screen started to flicker. There is no way to enter anything. Clicking the Add Languages button again makes the flickering stop. But I can not change te value there*.

Then I went to Formats and changed the setting there to United Kingdom - British English. Then I logged off and logged in again.
Then my interface was english but Leave still does not show reboot or shut down.

*I made a screen recording of this phenomenon to make clear what I mean. I used Kazam. But when I did that, though the screen started flickering again, after a second or so the flickering stopped. See here: https://imgur.com/a/itpzjM3

I'll reset Format to what it was before; will log out en log in again and will then try to change the language by running kazam whilst trying to add a language.

I'll report back asap.

Willem Hobers (whobers) said : #3

Hmmm, that did not go well. After trying to change formats again, logging out and logging in I started kazam and wanted to change the language. But the system then was unusable slow. I saw a message that no additional languages were installed. Stopping Kazam made the system usable again but it is still very slow. I'll reboot and will try again.

Willem Hobers (whobers) said : #4

Well, I'm sorry but I cant add a language due to the flickering screen. The work around with Kazam is not working because the system becomes unusable when I start kazam.

Not sure what to do next. Any advice?

If you make a fresh Ubuntu user and log in there, does it work OK?

Willem Hobers (whobers) said : #6

I created John Doe. Logging in as John I could add a language (the screen to do that worked as expected). Also: John DOES have a SHUT DOWN and REBOOT option in his main menu.

Willem Hobers (whobers) said : #7

BTW: For my own user, nothing seems to have changed.

Log in as your user then run:

groups

These are your users groups. If you run:

sudo groups user

(replace 'user' with John Doe's username), how is it different (if at all. I can imagine you didn't add John to the sudo group but this is fine).

Willem Hobers (whobers) said : #9

I think this is what you are asking:

willem@willem-kubuntu-001:~$ groups
willem adm cdrom sudo dip plugdev lpadmin lxd sambashare
willem@willem-kubuntu-001:~$ users
willem
willem@willem-kubuntu-001:~$ sudo groups john
[sudo] password for willem:
john : john
willem@willem-kubuntu-001:~$

Willem Hobers (whobers) said : #10

Not sure if this is related but:
Something else i noticed: I have set kubuntu to remember the session that is active when I shut down the laptop, and to use that session again when restarting. However it seems there is a particular session that is remembered. I just closed all applications on all virtual desktops and then rebooted. Nonetheless after loging in Kubuntu restored the applications that were active, not during my last session, but some older one I think. If I look at menu --> Desktop session --> On login, the option "restore previous session" is checked.

Apologies if this muddles the situation.

Willem Hobers (whobers) said : #11

As an attempt to add more info: whilst doing an sudo apt autoremove, I got these warnings:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "nl:en_US",
        LC_ALL = (unset),
        LANG = "en_NL.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
(Reading database ... 263992 files and directories currently installed.)
Removing linux-headers-5.4.0-28-generic (5.4.0-28.32) ...
Removing linux-headers-5.4.0-28 (5.4.0-28.32) ...
Removing linux-modules-extra-5.4.0-28-generic (5.4.0-28.32) ...
Removing linux-image-5.4.0-28-generic (5.4.0-28.32) ...
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

Bernard Stafford (bernard010) said : #12

In the KDE desktop hover the mouse pointer at the top right corner of the screen and click. Their should be a restart & shutdown
in the drop down menu list.

Willem Hobers (whobers) said : #13

Thank you, @bernard010, for the suggestion. I have no menu at the top right. I'll turn on the top right menu as a work around and see if that's a viable temporary solution.
But I would prefer to have the "shutdown" and "reboot" options in the place where they always used to be.

Willem Hobers (whobers) said : #14

Does any one have a suggestion on how to get the shut down and reboot options back in the main menu?

Best Bernard Stafford (bernard010) said : #15

https://askubuntu.com/questions/633318/save-session-settings-in-kde-environment-without-shutting-down

You can configure those settings: System settings -> Desktop session -> Default Leave options -> Turn off computer & Restart computer. -> Click Apply

Willem Hobers (whobers) said : #16

Thank you @bernard010, that seems to have done the trick! I can't for the life off me think how this option got turned off, but my leave menu is now as I wanted it to be.
Thanks!

Willem Hobers (whobers) said : #17

Thanks Bernard Stafford, that solved my question.