Cannot put chat window over buddy list

Asked by Brett Howard on 2008-04-04

Binary package hint: pidgin

I seem unable to place a chat window over the buddy list. When moving a chat window over to the area where the buddy list is it goes behind it. This is running compiz w/ the ATI drivers installed via the restricted drivers nugget (or whatever its called now). Running Hardy.

ProblemType: Bug
Architecture: i386
Date: Thu Apr 3 21:22:58 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/pidgin
NonfreeKernelModules: fglrx
Package: pidgin 1:2.4.0-1ubuntu2
PackageArchitecture: i386
ProcEnviron:
 PATH=/home/username/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/home/username/.Modelsim
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: pidgin
Uname: Linux 2.6.24-14-generic i686

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu pidgin Edit question
Assignee:
No assignee Edit question
Solved by:
Brett Howard
Solved:
2009-04-29
Last query:
2009-04-29
Last reply:
2009-04-29

This question was originally filed as bug #211662.

Daniel T Chen (crimsun) said : #2

Is this symptom still reproducible in 8.10 or 9.04?

This screenshot taken in 8.10 running Pidgin 2.5.2.

Plugins Running:
DBUS Example
Extended Preferences
History
Hotkeys
Libnotify Popups
Nautilus Integration
Pidgin-Encryption

Just looked at that picture again and I notice that the buddy list has focus. Even if the chat window is clicked on and given focus the buddy list remains on top as is pictured.

Should also state another difference from the original bug that I submitted. I'm now running the open source ATI drivers yet still running compiz. I just did a quick test and metacity does not fix the problem. I don't have my Metacity set to do compositing.

Sebastien Bacher (seb128) said : #6

the user list is set a sticky either using the wm or an option, that's not a bug

I deeply apologize gentlemen I recently figured out my issue when I upgraded to 9.04. Usually when I install Pidgin I simply copy over my .purple directory and drop in all the plugins that I use before even opening it for the first time. This time I just copied over .purple and then opened the app. At this point in time all worked how I wanted it to. Then I went back and installed all my plugins and restarted it. The problem then came back.. I later narrowed it down to the hotkeys plugin.

So this is *NOT* a bug in pidgin its a bug in the pidgin hotkeys plugin.