change dictionary for a single buddy (or use more than one)

Asked by Liox on 2008-05-31

Is there a possibility to change the dictionary for spell checking for a single buddy? I have contacts, where I'm speaking English with, and others where I'm speaking German.
Or may I can tell pidgin, to use more than one dictionary to spell check?

If this is not possible, how can I switch off the spell check at all. I'm really annoyed about the red line under almost every word.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu pidgin Edit question
Assignee:
No assignee Edit question
Solved by:
Liox
Solved:
2008-05-31
Last query:
2008-05-31
Last reply:
2008-05-31
Jens Maucher (jensmaucher) said : #1

Where? in Evolution? KMail? ...

Evolution:
Bearbeiten -> Einstellungen -> Editoreinstellungen -> Register: Rechtschreibpr├╝fung

Sorry, i have a german menu ;)

Liox (liox) said : #2

I looking for a solution for the pidgin IM
Sorry, may I should mention the application next time, but I thought if I write it in the right sub category it is clear.

Jens Maucher (jensmaucher) said : #3

Oups.. sorry. my fault. i was blind and didn't see it :-/

Jens Maucher (jensmaucher) said : #4

Ok, i checked my pidgin, and i found the following option.
(sorry, in german again)

Werkzeuge -> Einstellungen -> Unterhaltungen -> "Falsch geschriebene W├Ârter hervorheben" deaktivieren

Bhavani Shankar (bhavi) said : #5

Hello

You can setup both the languages and throttle between them.. Thats the easiest method I think

Go to System -> Administration -> Language Support. Scroll through the list and click the ones you want. Under input method, you can click "Enable support to enter complex characters" but I think it's not required. The system may install some packages and ask for a reboot. It's not required for most apps like Firefox, Pidgin IM, and maybe vim (with vim, it works in the terminal but that file in Firefox looks weird. probably character set or encoding issues).

The right click the panel/taskbar, Add To Panel, and select Keyboard Indicator from the Utilities section. That should put an indicator on your panel, right click and select Keyboard Preferences, Layouts. Click Add to add Germany to the list, and close it. Clicking on the panel indicator will switch input methods. Right click and Show Current Layout to see which (real) key produces which code

Regards

Bhavani Shankar.

Liox (liox) said : #6

thanks defcon, I had a closer look at pidgin and I found this option myself. But thats indeed the worst solution because I lost the spell check :(

Hello Bhavani,
thanks for your answer, but I don't have a problem with my keyboard, thats fine and I already installed the language support for English and German.
I'm looking for a way to tell pidgin to use the German, the English or may both dictionaries for spell checking. Just I can do that in Thunderbird.
I can't imagine I'm the only one which have this problem. There must be billions of people who speak different languages with different buddies.

Bhavani Shankar (bhavi) said : #7

Oops sorry for misunderstanding

These links might help you out:

http://ubuntuforums.org/showthread.php?t=563532

http://plugins.guifications.org/trac/wiki/PluginPack

Regards

Bhavani Shankar.

Liox (liox) said : #8

jippi, I found a solution !!! there is a add-on called switchspell, where you can switch the dictionary for different buddies... you can find it here: http://plugins.guifications.org/trac/wiki/switchspell

Bhavani Shankar (bhavi) said : #9

Glad that it was fixed mate...:)

ekso (ekso) said : #10

I don't get it, Switch Spell is exactly what I'm looking for also (I use English, Portuguese and Italian), I've installed the plugin pack, called pidgin-plugin-pack on Synaptic, but it didn't had Switch Spell. That package has:

/usr/lib/purple-2/autorejoin.so
/usr/lib/purple-2/autoreply.so
/usr/lib/purple-2/bash.so
/usr/lib/purple-2/dice.so
/usr/lib/purple-2/eight_ball.so
/usr/lib/purple-2/flip.so
/usr/lib/purple-2/highlight.so
/usr/lib/purple-2/ignore.so
/usr/lib/purple-2/irc-more.so
/usr/lib/purple-2/irchelper.so
/usr/lib/purple-2/listhandler.so
/usr/lib/purple-2/oldlogger.so
/usr/lib/purple-2/showoffline.so
/usr/lib/purple-2/simfix.so
/usr/lib/purple-2/slashexec.so
/usr/lib/purple-2/sslinfo.so
/usr/lib/pidgin/album.so
/usr/lib/pidgin/blistops.so
/usr/lib/pidgin/difftopic.so
/usr/lib/pidgin/gRIM.so
/usr/lib/pidgin/hideconv.so
/usr/lib/pidgin/irssi.so
/usr/lib/pidgin/lastseen.so
/usr/lib/pidgin/mystatusbox.so
/usr/lib/pidgin/nicksaid.so
/usr/lib/pidgin/plonkers.so
/usr/lib/pidgin/pidgin-schedule.so
/usr/lib/pidgin/sepandtab.so
/usr/lib/pidgin/xchat-chats.so

I went to http://plugins.guifications.org/trac/wiki/switchspell and there's no download link. And here http://plugins.guifications.org/trac/downloads there's binary only for Windows.

When will the plugin pack be upgraded? And/or where can I find the binary for Switch Spell for AMD64...? :)

I have some basic knowledge to compile and install, but a program, not a Pidgin plugin...

tibibo (dr-tibibo) said : #11

I'll be second here! There is no switchspell plugin in the pidgin-plugin-pack. I wonna see an any way to switch Pidgin's spellcheck "on-the-fly", while I typing in different languages. Specifically I permanently use English, Russian and Ukrainian languages and I need the way to switch quickly between them.
Any help?

P.S. It may be useful for someone: the "hard" way to switch aspell dictionaries in Pidgin is to use the ~/.aspell.conf file.
"lang" tag define the languages aspell will be use to.
In my case I have following in my ~/.aspell.conf:
~% cat .aspell.conf
 lang en_US
 #lang ru_RU
 #lang ru_UA

Phil Hannent (phil-hannent) said : #12

tibibo wrote:
> tibibo posted a new comment:
> I'll be second here! There is no switchspell plugin in the pidgin-plugin-pack. I wonna see an any way to switch Pidgin's spellcheck "on-the-fly", while I typing in different languages. Specifically I permanently use English, Russian and Ukrainian languages and I need the way to switch quickly between them.
> Any help?
There is a plugin (which I have never used) for this already:
http://developer.pidgin.im/wiki/Using%20Pidgin#HowdoIchangethelanguagefortheHighlightMisspelledwordsoption

http://plugins.guifications.org/trac/wiki/switchspell

Try installing the pidgin-guifications package:
http://packages.ubuntu.com/hardy/net/gaim-guifications

Regards
Phil Hannent

tibibo (dr-tibibo) said : #13

Phil Hannent, thank you for you answer. Yes, I know about this plugin. I had download and install the latest version of <a href="http://plugins.guifications.org/trac/downloads/2">purple-plugin_pack</a> (particulary it's 2.3.0 now) and it seems installation has finished successfuly. But nothing called like "switchspell" in Pidgin's plugins list has appeared. Perhaps I'm misunderstand something about how to use or how to enable this plugin, so would you mind to explain me something about?

Sincerely

SaschaVogt (funkyfish) said : #14

It should occur within the conversation window.
In the menu there should be an entry called "Spell Check" where you can select the language for that conversation.

HTH
-Sascha-

tibibo (dr-tibibo) said : #15

Sascha, unfortunately no. There is no entry called "Spell Check", only "Spelling suggestions" for the language, which define based on LC_MESSAGES locale, or for the one specified in ~/.aspell.conf
Something goes wrong and I'm really annoyed at it...
Please, any help

Sincerely

t.rei (shock) said : #16

Yes, the language support is somewhat rather lacking in gnome.

I am trying to avoid having to swap my whole interface to German in order to make my spell checking and things like decimal seperators work the way I want them, since I work and explain a lot to People all over the world, and English is the most common language.

Would be great to find a plugin (spellswitcher not being packaged anymore?) to be able to use multiple languages.

On the other hand, evolution currently accepts only one language at a time, too. It's really bugging me. I figure this needs to be fixed on the gtk-spellchecking level. Not per application.

Marius Gedminas (mgedmin) said : #17

The suggested workaround (echo 'lang en_US' > ~/.aspell.conf) does not work: even after restarting Pidgin I can't get it to check the spelling for anything other than lt_LT.

The switchspell plugin is not present in the pidgin-plugin-pack, despite the package description.

Why is this question marked as "solved"?

harcesz (harcesz) said : #18

bump, this is not solved and cripples pidgins functionality for multilingual users