pidgin buddy list synchronization bug

Asked by dextrose on 2008-02-20

Binary package hint: pidgin

everytime I start up pidgin, it always do the same thing:
please take a look at this screenshot: http://nothing.scene.org/dex/pidgin_problem.png

I have seen this is definitely not a ubuntu problem since I have been using mandriva also and my friend's pidgin also happens the same.

many thanks,
Jorge Nunes.

ProblemType: Bug
Architecture: amd64
Date: Wed Feb 20 13:19:37 2008
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/pidgin
NonfreeKernelModules: fglrx
Package: pidgin 1:2.2.1-1ubuntu4.1
PackageArchitecture: amd64
ProcCmdline: pidgin
ProcCwd: /home/jorge
ProcEnviron:
 SHELL=/bin/bash
 PATH=/home/jorge/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
SourcePackage: pidgin
Uname: Linux miunix 2.6.22-14-generic #1 SMP Tue Feb 12 02:46:46 UTC 2008 x86_64 GNU/Linux

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu pidgin Edit question
Assignee:
No assignee Edit question
Last query:
2008-02-20
Last reply:
2008-12-14

This question was originally filed as bug #193664.

dextrose (dextrose) said : #1
Pedro Villavicencio (pedro) said : #2

Thank you for your comments. This does not appear to be a bug report and we are closing it. We appreciate the difficulties you are facing, but it would make more sense to raise your question in the support tracker. https://answers.launchpad.net/ubuntu

See this bug report:

http://developer.pidgin.im/ticket/759

Your version of pidgin is 1:2.2.1, which is an older version. Upgrading it may help.

I had the same problem and after much fooling around I found on my system it was caused by the evolution integration plugin.....how I solved the problem

1) delete the ~/.purple folder (after backing up the log subfolder to keep all my old recorded conversations

2) restart pidgin, setting it back up the way I like, without evolution integration

and then closing pidgin and copying the log subfolder back into ~/.purple

then start the program again....no problems here now

I assume the buddy list sync problem had to do with old msn address' being saved in evolution

Eugene

pidgin 2.5 also has this in ubuntu looks similar to this debian bug
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=434089
(Buddy list synchronization issue in <foo> not handled correctly. In a certain state the message "Buddy list synchronization issue in ..." can popup with at least an MSN account. Two choices are given. Choosing _either_ does not resolve the issue, since after a restart of pidgin the same message pops up again.

So, the problem is that Pidgin detects a problem, claims to have two possible solutions, but none of the offered solutions are effective. )

Certainly linked with pidgin Evolution plugin. To recreate enable evolution plugin, sync contacts, disable evolution plugin restart pidgin

Deleting the ~/.purple folder works. Also backup the accounts.xml file so as you don't have to set them all up again

Matias (falle) said : #6

Hi,

I don't know what the exact original problem was since the screenshot describing the problem is not available anymore, but you might want to have a look at this web page on the Pidgin website that provided a workaround for me: http://developer.pidgin.im/wiki/Protocol%20Specific%20Questions#WhydoIkeepgettingaBuddyListSynchronizationerror

Matias

Can you help with this problem?

Provide an answer of your own, or ask dextrose for more information if necessary.

To post a message you must log in.