Pidgin fails to install on Xubuntu 12.04 unstable

Asked by Kunal Ghosh on 2012-04-02

Pidgin was recently removed from my Xubuntu 12.04 installation becuase of dependency problem.
If I try to install Pidgin, dependencies Perlapi-5.12.4 and Pidgin-libnotify are not satisfied.
In the installation, Perlapi-5.12.4 has been superseeded by Perlapi-5.14.x.

Any way to reinstall Pidgin?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu pidgin Edit question
Assignee:
No assignee Edit question
Solved by:
Kunal Ghosh
Solved:
2012-04-03
Last query:
2012-04-03
Last reply:
2012-04-03

Until deps are met, no. I suggest you report a bug. Precise is not ready and not stable and you will see issues running up to and even a few weeks after release

Kunal Ghosh (kghosh22) said : #2

Please direct me how to file a bug for Pidgin

run:

ubuntu-bug pidgin

Kunal Ghosh (kghosh22) said : #4

The response was -

"The problem cannot be reported:

This is not an official Ubuntu package. Please remove any third party package and try again."

What next?

what is the output of:

apt-cache policy pidgin

users with the skill level are not intended for prereleases.

Kunal Ghosh (kghosh22) said : #6

pidgin:
  Installed: (none)
  Candidate: 1:2.10.3-1~getdeb1
  Version table:
     1:2.10.3-1~getdeb1 0
        500 http://archive.getdeb.net/ubuntu/ oneiric-getdeb/apps amd64 Packages
     1:2.10.2-1ubuntu1 0
        500 http://in.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

sudo apt-get --purge remove pidgin; grep -R oneiric /etc/apt

What is output?

Thanks

Kunal Ghosh (kghosh22) said : #8

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package pidgin is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
grep: /etc/apt/trustdb.gpg: Permission denied
/etc/apt/sources.list.save:deb http://archive.getdeb.net/ubuntu oneiric-getdeb apps
/etc/apt/sources.list.save:deb-src http://archive.getdeb.net/ubuntu oneiric-getdeb apps
/etc/apt/sources.list:deb http://archive.getdeb.net/ubuntu oneiric-getdeb apps
/etc/apt/sources.list:deb-src http://archive.getdeb.net/ubuntu oneiric-getdeb apps

ok run:

sudo rm /etc/apt/sources.list.save; gksudo gedit /etc/apt/sources.list

any lines with oneiric on, put a hash character at the start of them, save the new file. Close gedit and run:

sudo apt-get --purge remove pidgin; sudo apt-get --purge autoremove; sudo apt-get update; sudo apt-get clean; sudo apt-get install pidgin

Kunal Ghosh (kghosh22) said : #10

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 pidgin : Depends: pidgin-data (< 1:2.10.2-z) but 1:2.10.3-1~getdeb1 is to be installed
          Recommends: pidgin-libnotify but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

The dependency has changed now.

You missed an oneiric line, you have the getdeb repo enabled which is causing issues

Kunal Ghosh (kghosh22) said : #12

Ok, Done it.

Went into Synaptic and selected all references to Pidgin and "Completely uninstalled" all of them.

Selcted Pidgin again and installed it with all its dependencies.

Now Pigin is happily working.

Thanls for your effort.

If you can't resolve simple stuff lie this you shouldn't be using Pre-releases. Precise is NOT ready and NOT stable and you will get issues like this all the way up to and even a few weeks after release

andrew-woodhead666, an attitude like that is NOT appropriate. I was having the same problem and I was NOT using the pre-release but upgraded from Ubuntu 11.10 and my old PPAs were still in my sources list. Removing them fixed it though, thanks. I'm happily purpl'ing away again, thanks! =)

Its very appropriate. The website even says words to the effect of "This will break a lot", so normal users with limited Linux ability should not use pre-release, it's madness.