Pidgin not connecting to GTalk

Asked by NakiMum on 2012-02-29

I've got Ubuntu 11.10 on HP Pavilion DV6 and everything is running smoothly, except for Pidgin 2.10.0 not connecting to GTalk. I've tried both the GMail address I have and neither work. I'm also connected to MXit and MSN without any problems. I don't have Yahoo to test with. Facebook also isn't connecting. Could it be some settings with XMPP that I'm missing?
I did do a debug on GTalk, this is the output:

(09:40:13) account: Connecting to account <email address hidden>/.
(09:40:13) connection: Connecting. gc = 0x7f7139a1f580
(09:40:13) dnssrv: querying SRV record for gmail.com: _xmpp-client._tcp.gmail.com
(09:40:13) dnssrv: found 5 SRV entries
(09:40:13) dnsquery: Performing DNS lookup for xmpp.l.google.com
(09:40:13) dns: Wait for DNS child 3338 failed: No child processes
(09:40:13) dns: Created new DNS child 3364, there are now 1 children.
(09:40:13) dns: Successfully sent DNS request to child 3364
(09:40:13) dns: Got response for 'xmpp.l.google.com'
(09:40:13) dnsquery: IP resolved for xmpp.l.google.com
(09:40:13) proxy: Attempting connection to 209.85.225.125
(09:40:13) proxy: Connecting to xmpp.l.google.com:5222 with no proxy
(09:40:13) proxy: Connection in progress
(09:40:13) proxy: Connecting to xmpp.l.google.com:5222.
(09:40:13) proxy: Connected to xmpp.l.google.com:5222.
(09:40:13) jabber: Sending (<email address hidden>): <?xml version='1.0' ?>
(09:40:13) jabber: Sending (<email address hidden>): <stream:stream to='gmail.com' xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' version='1.0'>
(09:40:16) util: Writing file prefs.xml to directory /home/vi4/.purple
(09:40:16) util: Writing file /home/vi4/.purple/prefs.xml
(09:40:18) jabber: Recv (379): <stream:stream from="gmail.com" id="7C9391201FC927FA" version="1.0" xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client"><stream:features><starttls xmlns="urn:ietf:params:xml:ns:xmpp-tls"><required/></starttls><mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><mechanism>X-GOOGLE-TOKEN</mechanism><mechanism>X-OAUTH2</mechanism></mechanisms></stream:features>
(09:40:18) jabber: Sending (<email address hidden>): <starttls xmlns='urn:ietf:params:xml:ns:xmpp-tls'/>
(09:40:18) util: Writing file accounts.xml to directory /home/vi4/.purple
(09:40:18) util: Writing file /home/vi4/.purple/accounts.xml
(09:40:18) jabber: Recv (50): <proceed xmlns="urn:ietf:params:xml:ns:xmpp-tls"/>
(09:40:19) nss: subject=CN=gmail.com,O=Google Inc,L=Mountain View,ST=California,C=US issuer=CN=Google Internet Authority,O=Google Inc,C=US
(09:40:19) nss: subject=CN=Google Internet Authority,O=Google Inc,C=US issuer=OU=Equifax Secure Certificate Authority,O=Equifax,C=US
(09:40:19) nss: subject=OU=Equifax Secure Certificate Authority,O=Equifax,C=US issuer=OU=Equifax Secure Certificate Authority,O=Equifax,C=US
(09:40:19) certificate/x509/tls_cached: Starting verify for gmail.com
(09:40:19) certificate/x509/tls_cached: Checking for cached cert...
(09:40:19) certificate/x509/tls_cached: ...Found cached cert
(09:40:19) nss/x509: Loading certificate from /home/vi4/.purple/certificates/x509/tls_peers/gmail.com
(09:40:19) certificate/x509/tls_cached: Peer cert matched cached
(09:40:19) nss/x509: Exporting certificate to /home/vi4/.purple/certificates/x509/tls_peers/gmail.com
(09:40:19) util: Writing file /home/vi4/.purple/certificates/x509/tls_peers/gmail.com
(09:40:19) certificate: Successfully verified certificate for gmail.com
(09:40:19) jabber: Sending (ssl) (<email address hidden>): <stream:stream to='gmail.com' xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' version='1.0'>
(09:40:19) jabber: Recv (ssl)(138): <stream:stream from="gmail.com" id="9A299729CEE4B9A5" version="1.0" xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client">
(09:40:19) jabber: Recv (ssl)(197): <stream:features><mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><mechanism>PLAIN</mechanism><mechanism>X-GOOGLE-TOKEN</mechanism><mechanism>X-OAUTH2</mechanism></mechanisms></stream:features>
(09:40:19) sasl: sasl_state is -1, failing the mech and trying again
(09:40:19) connection: Connection error on 0x7f7139a1f580 (reason: 3 description: Server does not use any supported authentication method)
(09:40:19) account: Disconnecting account <email address hidden>/ (0x7f7139906c80)
(09:40:19) connection: Disconnecting connection 0x7f7139a1f580
(09:40:19) jabber: Sending (ssl) (<email address hidden>): </stream:stream>
(09:40:19) connection: Destroying connection 0x7f7139a1f580

TIA

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu pidgin Edit question
Assignee:
No assignee Edit question
Solved by:
arochester
Solved:
2012-02-29
Last query:
2012-02-29
Last reply:
2012-02-29
Best arochester (arochester) said : #1

In mine I put
1) Username: myusername
2) Domain: gmail.com
3) Password: mypassword
4) Remember Password

THEN, click the Advanced Tab
5) Connect Server: talk.google.com

You should then get a Certificate

NakiMum (nakimum) said : #2

Thanks arochester, that solved my question.

Tomas Hayes (tomyo) said : #3

Had same problem in ubuntu 12.10 with pidgin, this solved!

Thanks!

Michal Palma (michal-palma) said : #4

I clicked authorise certificate and get only "not authorised" message in pidgin. When i manualy delete certificate from home/.purple, its the same again.
I have everything defined as you wrote. Does'nt work..