Will PHP 5.5.12 (or above) be included in trusty?

Asked by Patrik Lermon on 2015-05-06

The current PHP version in trusty is 5.5.9+dfsg-1ubuntu4.9
Will ever PHP 5.5.12 version be included in trusty?

I'm specifically looking for the fix for apr_psprintf format string to be able to log php memory usage in apache log (see http://tech.superhappykittymeow.com/?p=220). However current apache and php are not compatible so memory usage is not logged (see http://stackoverflow.com/questions/21549852/apache-mod-php-memory-usage-prints-zu-instead-of-useful-data).

PHP pull request where this was fixed (merged into 5.5.12): https://github.com/php/php-src/pull/641
Apache bug which caused the problem: https://bz.apache.org/bugzilla/show_bug.cgi?id=56120

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu php5 Edit question
Assignee:
No assignee Edit question
Last query:
2015-05-06
Last reply:
2015-05-06

I suggest you report a bug to alert the devs to these issues

Patrik Lermon (patrik-gnupung) said : #2

I'm not sure I want to create a bug out of this, since the bug is already fixed upstreams.
It depends on how package maintainers would like to handle it.
Is it possible to get feedback from package maintainers on how to handle this one?

Can you help with this problem?

Provide an answer of your own, or ask Patrik Lermon for more information if necessary.

To post a message you must log in.