How to Install php 5.3.10-1ubuntu3.14

Asked by Kent Maxwell on 2014-11-30

Hello,

I am experiencing problems with my PHP application with 5.3.10-1ubuntu3.15. I have identified what the problem is, but in the meanwhile I would like to downgrade to 5.3.10-1ubuntu3.14, because the application ran fine with this version.

I have tried to use this command in Ubuntu:
apt-get install php5=5.3.10-1ubuntu3.14

However it is not working. It claims it can not find this version. How can I install 5.3.10-1ubuntu3.14?

Thanks,

Kent

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu php5 Edit question
Assignee:
No assignee Edit question
Last query:
2014-12-01
Last reply:
2014-12-01

What is the output of :

lsb_release -a; uname -a

Thanks

Kent Maxwell (kent-1) said : #2

Here is that output:

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.5 LTS
Release: 12.04
Codename: precise
Linux lms 3.11.0-26-generic #45~precise1-Ubuntu SMP Tue Jul 15 04:02:35 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Kent Maxwell (kent-1) said : #4

Where would I find the packages for these components that go with this release:

libapache2-mod-php5
php5-mcrypt
libapache2-mod-suphp

Keep in mind that I am looking of the 5.3.10-1ubuntu3.14 version

Manfred Hampl (m-hampl) said : #5

According to https://launchpad.net/ubuntu/+source/php5/+publishinghistory

2014-10-30 13:00:52 UTC Superseded Precise updates main php 5.3.10-1ubuntu3.14
Removed from disk on 2014-10-31.
Removal requested on 2014-10-31.
Superseded on 2014-10-30 by php5 - 5.3.10-1ubuntu3.15

Due to the fact that the ...3.14 version has been superseded by the ...3.15 version, the older version has been removed from the normal repositories.
From the changelog I see that the ...3.15 version has five security patches included. Are you sure that the problems that you experience are really caused by the ...3.15 update?

If you really need the ...3.14 files, they would be available on https://launchpad.net/~ubuntu-security/+archive/ubuntu/ppa/+build/6321011 and https://launchpad.net/~ubuntu-security/+archive/ubuntu/ppa/+build/6321014 but I really cannot recommend downgrading to that version.

Can you help with this problem?

Provide an answer of your own, or ask Kent Maxwell for more information if necessary.

To post a message you must log in.