how to enable XSL (XML style translation sheet) in ubuntu 11.04

Asked by engynazmy on 2011-11-12

I've installed the XSL through this command "sudo apt-get install php5-xsl" but i couldn't add this line "extension=php_xsl.dll" to my php.ini to enable it although I changed its permissions .. always refuses to save .. please advice?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu php5 Edit question
Assignee:
No assignee Edit question
Solved by:
engynazmy
Solved:
2011-11-13
Last query:
2011-11-13
Last reply:
2011-11-13
Sam_ (and-sam) said : #1

xsl and dll are Windows file extensions, not sure, but maybe you need wine.
https://help.ubuntu.com/community/Wine

Jacobsallan (jacobsallan) said : #2

xsl is the suffix for an XML style translation sheet. ( http://www.w3.org/TR/xslt ). These should work on all operating systems.

Configuration on Linux (and Windows) is documented at
https://wiki.mahara.org/index.php/Plugins/Artefact/Europass/Configuring_and_Testing_PHP_Servers_for_XSL_Support. The configuration steps are different. Configuration on Linux does not involve a line "extension=php_xsl.dll".

Is this enough information?

engynazmy (ianees) said : #3

Many thanks friends for your help .. am not sure how it worked but I tested my server with the phpinfo() .. and found the XSL settings are working ..

XSL enabled
libxslt Version 1.1.26
libxslt compiled against libxml Version 2.7.8
EXSLT enabled
libexslt Version 1.1.26