How disable suhosin on 10.04 or allow configuration

Asked by Marc Kraak on 2011-05-24

I need to disable suhosin or let the suhosin patch use it parameters
Putting suhosin.executor.include.whitelist = tmpl://, file:// in php.ini or suhosin.ini is ignored
I'm using the fastcgi mode
Php info reports that /etc/php5/cgi/conf.d/suhosin.ini is actually parsed, but no configuration seems to be used
I tried to put the line in the .htaccess file but this also doesn't work
So this doesn't work http://www.assembla.com/wiki/show/nooku-framework/Known_Issues

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu php5 Edit question
Assignee:
No assignee Edit question
Last query:
2011-05-24
Last reply:
2011-05-30
Rowan Wookey (rwky) said : #1

Suhosin ini options in ubuntu's php since it uses the suhosin patch not the extension, from the suhosin website

"When you only use the Suhosin-Patch only the logging features are supported. When you only use the Suhosin-Extension you cannot use the predefined constants for configuration. This is due to the way php.ini constant support is implemented in PHP."

http://www.hardened-php.net/suhosin/configuration.html

Can you help with this problem?

Provide an answer of your own, or ask Marc Kraak for more information if necessary.

To post a message you must log in.