Ubuntu 10.04 LTS and PHP 5.3

Asked by Manuel Lino on 2010-05-29

After updating to LTS, PHP 5.3 was installed. Since then, I have a Deprecated warning regarding Mail.php, wich is part of PHP Pear Package. How to get rid of this warning?

Thanks,
Manuel

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu php5 Edit question
Assignee:
No assignee Edit question
Solved by:
François Tissandier
Solved:
2010-05-29
Last query:
2010-05-29
Last reply:
2010-05-29
Best François Tissandier (baloo) said : #1

You can use this function in your code:

error_reporting(E_ALL ^ E_DEPRECATED);

This is just an exemple to report all errors, except the deprecated ones. If you want to remove other errors, check this:
http://php.net/manual/en/function.error-reporting.php

If you want to set this in your PHP.ini to make sure it works on every page, but i'm not sure about the syntax. That's probably the easier solution for you now.

Manuel Lino (mc-lino) said : #2

Thanks François.

Manuel Lino (mc-lino) said : #3

Thanks François Tissandier, that solved my question.