Trying to run `phan`, which requires php-ast 1.0.1+, would be nice if this could get a version bump

Asked by Henk Poley on 2019-08-27

```
$ ./vendor/bin/phan
ERROR: Phan 2.x requires php-ast 1.0.1+ because it depends on AST version 70. php-ast 0.1.6 is installed.
Exiting without analyzing files.
```

Current php-ast in ubuntu is from 2015.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu php-ast Edit question
Assignee:
No assignee Edit question
Last query:
2019-08-27
Last reply:
2019-08-27
Manfred Hampl (m-hampl) said : #1

Manfred Hampl suggests this article as an answer to your question:
FAQ #3037: “no rolling release”.

Manfred Hampl (m-hampl) said : #2

Ubuntu 19.10 (the development release, to be published in October) will contain php-ast version 1.0.3-1 (or higher).

What you could try is manually downloading and installing php-ast for eoan on your current system. I do not see any complicated dependencies, and I assume that the package would be installable already on Ubuntu bionic and newer.

Can you help with this problem?

Provide an answer of your own, or ask Henk Poley for more information if necessary.

To post a message you must log in.