perl 5.20 missing fakethe.h perlsfio.h

Asked by Sebastian Podjasek on 2014-11-07

Not sure that this is Ubuntu/Debian issue but after upgrading 14.04 to 14.10 (with new perl package 5.20) due to lack of these two files I wasn't able to build for ex. Session::Token module from source.

Solution was simple:
sudo touch /usr/lib/x86_64-linux-gnu/perl/5.20/CORE/fakethr.h
sudo touch /usr/lib/x86_64-linux-gnu/perl/5.20/CORE/perlsfio.h

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu perl Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2014-11-08
Last query:
2014-11-08
Last reply:
2014-11-08

I suggest you report a bug and your fix can be made default :-)

You didn't mention which version of Ubuntu you are using. This is crucial information to provide.

I assume you have this issue because you are probably running Ubuntu 14.10.

Ubuntu 14.04 LTS has those missing files. Ubuntu 14.10 does not have them (yet).

They are both in the perl Ubuntu package, but only for 14.04 LTS.

Thanks actionparsnip, that solved my question.

markrijckenberg: fixed, I though that package version will be enough - 14.04 LTS was based on perl 5.18, 14.10 introduced 5.20 with this bug