need pepflashplugin-installer for Ubuntu 12.10

Asked by Papouchi on 2015-02-05

I want to get a new version of flashplayer for firefox (my Ubuntu = 12.10).
I've already installed freshplayerplugin, but I can't find pepperflashplugin-nonfree.

Following <http://linuxg.net/how-to-install-pepper-flash-player-12-0-on-ubuntu-14-0413-1013-0412-1012-04-linux-mint-16151413-pear-os-87-and-elementary-os-0-2/> I've tried to install pepflashplugin-installer, but it is not found :

$ sudo add-apt-repository ppa:skunk/pepper-flash
$ sudo apt-get update
$ sudo apt-get install pepflashplugin-installer
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet pepflashplugin-installer
$

And so, if I try to install pepperflashplugin-nonfree, it's not working as well :

$ sudo apt-get install pepperflashplugin-nonfree
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet pepperflashplugin-nonfree n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
E: Le paquet « pepperflashplugin-nonfree » n'a pas de version susceptible d'être installée
$

Where could I find a package of pepflashplugin-installer for my Ubuntu 12.10 ?

Thanks for all answer !

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu pepperflashplugin-nonfree Edit question
Assignee:
No assignee Edit question
Last query:
2015-02-10
Last reply:
2015-02-10

This question was reopened

Quantal is no longer supported nad there are no packages for it.

I suggest you upgrade to Trusty ASAP. Trusty is LTS and supported til April 2019.

Papouchi (papouchi) said : #2

OK, this is the "official" answer. But I don't understand something. This package did exist, didn't it ? People with Ubuntu 12.10 still use it, don't they ? So why couldn't I get the package from a user ?
I don't have nothing against Trusty, but I don't have enough RAM.

Manfred Hampl (m-hampl) said : #3

If you look at https://wiki.ubuntu.com/Releases you see that support for Ubuntu 12.10 ended nine months ago. There are no updates any more, not even for critical vulnerabilities like those that were in the news a few weeks ago.
If your hardware is not capable of running Ubuntu 14.04 LTS, then you should have stayed on Ubuntu 12.04 LTS, with support until April 2017.

If I look at the skunk/pepper-flash PPA, it seems to me that the packages for the different Ubuntu releases are identical. Manually installing the package for precise on your quantal system might work. But I have to repeat that this is not supported at all, and you are running a system that is insecure and might be vulnerable to attacks.

Papouchi (papouchi) said : #4

This is great. I understand what you say, that I should move back to the 12.04 version. For curiosity, I'd like to know, how can I manually install the package for precise on my quantal system ? I understand that the solution is not secure, but I'd like to try, maybe untill I'll move back to the precise version.

Papouchi (papouchi) said : #5

Thanks Manfred Hampl, that solved my question.

Manfred Hampl (m-hampl) said : #6

For completeness sake:

You would have to download https://launchpad.net/~skunk/+archive/ubuntu/pepper-flash/+files/pepflashplugin-installer_16.0.0.305~cr40.0.2214.95-1-0skunk0_amd64.deb or https://launchpad.net/~skunk/+archive/ubuntu/pepper-flash/+files/pepflashplugin-installer_16.0.0.305~cr40.0.2214.95-1-0skunk0_i386.deb (depending whether you have a 32 bit or 64 bit installation), and then try installing with "sudo dpkg --install pepflash*.deb"
If that fails with dependency problems, you would have to install the required additional packages with apt-get and re-try "sudo dpkg --configure -a", and if you get another dependency problem repeat apt-get with the new package(s) and so on until you have success.

Papouchi (papouchi) said : #7

 It did work wonderful :-)

$ sudo dpkg --install pepflashplugin-installer_16.0.0.305~cr40.0.2214.95-1-0skunk0_i386.debSélection du paquet pepflashplugin-installer précédemment désélectionné.
(Lecture de la base de données... 203125 fichiers et répertoires déjà installés.)
Dépaquetage de pepflashplugin-installer (à partir de pepflashplugin-installer_16.0.0.305~cr40.0.2214.95-1-0skunk0_i386.deb) ...
Paramétrage de pepflashplugin-installer (16.0.0.305~cr40.0.2214.95-1-0skunk0) ...
Traitement des actions différées (« triggers ») pour « update-notifier-common »...
pepflashplugin-installer: downloading https://dl-ssl.google.com/linux/chrome/deb/pool/main/g/google-chrome-stable/google-chrome-stable_40.0.2214.95-1_i386.deb
$

But then there is a windows that tell me that I need to download additional data, and when I try to do it, a new windows LXTerminal open, with a message that ask me to give my password before to launch the programme /usr/lib/update-notifier/package-data-downloader, and when I do it, nothing happens. The windows is closing, and I stay with the first message that I need to download additional data.

Maybe you have an idea what I should do ?

Papouchi (papouchi) said : #8

Well, after consideration, I suppose that the problem is now with google, and this is not something that you can fix.
However, I'd like to thanks you a lot for you tried to help, even beyond what is "conventional".

I will move in an other few months to something that is "supported". Meanwhile, ple

Papouchi (papouchi) said : #9

This site is not easy for somebody like me, that is not "expert". It takes messages that are not finished and makes them finished. However I'd like to thanks you a lot for you tried to help me beyond the "conventional".

About my question, I suppose that the problem is now with google, and this is not something that you can fix. If I do a mistake, please tell me :-)

Install a supported release and you wont have any issues.

12.10 is dead

Manfred Hampl (m-hampl) said : #11

Meanwhile there was a release upgrade with Google chrome, and an update of the skunk/pepper-flash PPA.

Maybe downloading and installing https://launchpad.net/~skunk/+archive/ubuntu/pepper-flash/+files/pepflashplugin-installer_16.0.0.305~cr40.0.2214.111-1-0skunk0_i386.deb will work.

And again, if you had a supported release running, these issues should be solved automatically.

Papouchi (papouchi) said : #12

Thank you very much for your answer. In fact I'm exhausted... I've worked on this all the day, everything seems to be allright, but I still don't get nothing if I go for exemple to youtube. When I've tried after installing the new file, there was a short start oh sound, and then finished. Even the black place of the video is not there.

I don't understand, it seems to be installed :

x@x-AOA110:/opt/flash_player$ sudo dpkg --install pepflashplugin-installer_16.0.0.305~cr40.0.2214.111-1-0skunk0_i386.deb
(Lecture de la base de données... 203221 fichiers et répertoires déjà installés.)
Préparation du remplacement de pepflashplugin-installer 16.0.0.305~cr40.0.2214.111-1-0skunk0 (en utilisant pepflashplugin-installer_16.0.0.305~cr40.0.2214.111-1-0skunk0_i386.deb) ...
Dépaquetage de la mise à jour de pepflashplugin-installer ...
Paramétrage de pepflashplugin-installer (16.0.0.305~cr40.0.2214.111-1-0skunk0) ...
Traitement des actions différées (« triggers ») pour « update-notifier-common »...
x@x-AOA110:/opt/flash_player$

x@x-AOA110:~$ apt-cache show pepflashplugin-installer
Package: pepflashplugin-installer
Source: pepflashplugin-nonfree
Priority: optional
Section: web
Installed-Size: 56
Maintainer: Daniel Richard G. <email address hidden>
Architecture: i386
Version: 16.0.0.305~cr40.0.2214.111-1-0skunk0
Recommends: chromium-browser (>= 23.0)
Suggests: x-ttcidfont-conf, ttf-mscorefonts-installer, ttf-bitstream-vera | ttf-dejavu, ttf-xfree86-nonfree, xfs
Depends: debconf (>= 0.5) | debconf-2.0, libc6, libgcc1, libstdc++6, update-notifier-common (>= 0.119ubuntu2)
Filename: pool/main/p/pepflashplugin-nonfree/pepflashplugin-installer_16.0.0.305~cr40.0.2214.111-1-0skunk0_i386.deb
Size: 6612
MD5sum: b1bed4684be6d1434fe5e83a39255552
SHA1: 4381b27642669e20ac406ae34978391300a742b5
SHA256: f4d2169b318ce945d17bb7f48fb5a2323da277ff4bde2543f5460c443ef6d566
Description-en: Adobe/Google Pepper Flash Player plugin installer
 Downloads and installs the Adobe/Google "Pepper" (PPAPI) Flash Player
 plugin. This plugin supports the playback of media and other dynamic
 content online.
 .
 Note that the Pepper Flash Player plugin is currently supported only by
 the Chromium Web browser (as well as its non-free derivative, Google
 Chrome, which already includes the plugin).
 .
 WARNING: Installing this package will cause the Pepper Flash Player plugin
 to be downloaded from the Google Web site. The distribution license of the
 Pepper Flash Player plugin is available at http://google.com/chrome/ .
 Installing this package implies that you have accepted the terms of that
 license.
Description-md5: 225cd7e658ac04b24e22d3bc76a4e20a
Multi-Arch: foreign
x@x-AOA110:~$

x@x-AOA110:~$ ls -l /etc/apt/sources.list.d
total 8
-rw-r--r-- 1 root root 140 févr.  7 16:19 skunk-pepper-flash-precise.list
-rw-r--r-- 1 root root 144 févr.  7 16:19 skunk-pepper-flash-precise.list.save
x@x-AOA110:~$
x@x-AOA110:~$ cat /etc/apt/sources.list.d/skunk-pepper-flash-precise.list
deb http://ppa.launchpad.net/skunk/pepper-flash/ubuntu precise main
deb-src http://ppa.launchpad.net/skunk/pepper-flash/ubuntu precise main
x@x-AOA110:~$
x@x-AOA110:~$ cat /etc/apt/sources.list.d/skunk-pepper-flash-precise.list.save
# deb http://ppa.launchpad.net/skunk/pepper-flash/ubuntu precise main
# deb-src http://ppa.launchpad.net/skunk/pepper-flash/ubuntu precise main
x@x-AOA110:~$

Plugins installed :

Shockwave Flash
    Fichier : libflashplayer.so
    Chemin : /usr/lib/flashplugin-installer/libflashplayer.so
    Version : 11.2.202.425
    État : Activé (STATE_VULNERABLE_UPDATE_AVAILABLE)
    Shockwave Flash 11.2 r202

Shockwave Flash
    Fichier : libfreshwrapper.so
    Chemin : /usr/lib/mozilla/plugins/libfreshwrapper.so
    Version : 13.1.2.3
    État : Activé
    Shockwave Flash 13.1 r2

But no pepperflashplugin-nonfree :

x@x-AOA110:/opt/flash_player$ sudo apt-get install pepperflashplugin-nonfree
[sudo] password for martine:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet pepperflashplugin-nonfree n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « pepperflashplugin-nonfree » n'a pas de version susceptible d'être installée
x@x-AOA110:/opt/flash_player$

(E = The package « pepperflashplugin-nonfree » doesn't have any version that can be installed)

Please, do you see something wrong that can explain that it doesn't work ? I'm beginner in linux, I don't understand enough what is going on.

---- Message d'origine ----
De : "Manfred Hampl" <email address hidden>
À : <email address hidden>
Objet : Re: [Question #261710]: need pepflashplugin-installer for Ubuntu 12.10
Date : 07/02/2015 14:41:32 CET

Your question #261710 on pepperflashplugin-nonfree in Ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/pepperflashplugin-nonfree/+question/261710

Manfred Hampl proposed the following answer:
Meanwhile there was a release upgrade with Google chrome, and an update
of the skunk/pepper-flash PPA.

Maybe downloading and installing
https://launchpad.net/~skunk/+archive/ubuntu/pepper-flash/+files
/pepflashplugin-installer_16.0.0.305~cr40.0.2214.111-1-0skunk0_i386.deb
will work.

And again, if you had a supported release running, these issues should
be solved automatically.

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+source/pepperflashplugin-nonfree/+question/261710/+confirm?answer_id=10

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+source/pepperflashplugin-nonfree/+question/261710

You received this question notification because you asked the question.

Papouchi (papouchi) said : #13

I think I'm missing a something, but I don't know what. I have uninstalled everything, and then installed again, and everything seems fix, but it is not working :

x@x-AOA110:/$ cat /etc/apt/sources.list
# deb cdrom:[Lubuntu 12.04 _Precise Pangolin_ - Release i386 (20120423)]/ precise main multiverse restricted universe
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb ftp://ftp.rezopole.net/ubuntu/ quantal main
deb-src ftp://ftp.rezopole.net/ubuntu/ quantal main universe #Added by software-properties
## Major bug fix updates produced after the final release of the
## distribution.

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb ftp://ftp.rezopole.net/ubuntu/ quantal universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu precise partner
# deb-src http://archive.canonical.com/ubuntu precise partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
# deb http://extras.ubuntu.com/ubuntu quantal main
# deb-src http://extras.ubuntu.com/ubuntu quantal main
deb http://security.ubuntu.com/ubuntu/ quantal-security universe main
deb ftp://ftp.rezopole.net/ubuntu/ quantal-updates universe main
deb http://ppa.launchpad.net/skunk/pepper-flash/ubuntu precise main

x@x-AOA110:/$

sudo apt-get update, and then :

x@x-AOA110:/$ sudo apt-get install pepflashplugin-installer
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Paquets suggérés :
  x-ttcidfont-conf ttf-mscorefonts-installer ttf-bitstream-vera ttf-dejavu
  ttf-xfree86-nonfree xfs
Les NOUVEAUX paquets suivants seront installés :
  pepflashplugin-installer
0 mis à jour, 1 nouvellement installés, 0 à enlever et 3 non mis à jour.
Il est nécessaire de prendre 0 o/6 612 o dans les archives.
Après cette opération, 57,3 ko d'espace disque supplémentaires seront utilisés.
Préconfiguration des paquets...
Sélection du paquet pepflashplugin-installer précédemment désélectionné.
(Lecture de la base de données... 203212 fichiers et répertoires déjà installés.)
Dépaquetage de pepflashplugin-installer (à partir de .../pepflashplugin-installer_16.0.0.305~cr40.0.2214.111-1-0skunk0_i386.deb) ...
Traitement des actions différées (« triggers ») pour « update-notifier-common »...
pepflashplugin-installer: downloading https://dl-ssl.google.com/linux/chrome/deb/pool/main/g/google-chrome-stable/google-chrome-stable_40.0.2214.111-1_i386.deb
Extracting plugin files from /tmp/tmpzNZUTG.deb ...
Pepper Flash plugin installed.
Paramétrage de pepflashplugin-installer (16.0.0.305~cr40.0.2214.111-1-0skunk0) ...
x@x-AOA110:/$

Is there an action that I've forgotten ? Thank you very much if you will help me to finish the work !

Manfred Hampl (m-hampl) said : #14

Which web browser are you using? Firefox, or Chrome (Chromium)? You have to be aware that the pepper flash player only works for Chrome (Chromium).

What is the output of the following commands

sudo updatedb
locate libpep

Can you start you web browser(s) and navigate to
http://www.adobe.com/software/flash/about/
You should see in a box the information "Version information / You have version xxx.xxx.xxx.xxx installed"
What version number do you see?

It seems that there will not be much choice except a new installation of a supported Ubuntu release.

Papouchi (papouchi) said : #15

Manfred Hampl requested more information:
Which web browser are you using? Firefox, or Chrome (Chromium)? You have
to be aware that the pepper flash player only works for Chrome
(Chromium).

>> I'm using Firefox, and this is on Firefox that I don't succeed to see video anymore. But I've installed the freshplayerplugin that is supposed to use the pepperflashplugin-nonfree (http://doc.ubuntu-fr.org/flashplayer) to allow flashplayer also on Firefox.
I have also Chromium, and on Chromium I can see video, but as far I understand it's without the pepper flash player, because if I ask the system it tells me that the package is virtual and is not found :
x@x-AOA110:~$ apt-cache show pepperflashplugin-nonfree
N: Impossible de choisir les versions du paquet « pepperflashplugin-nonfree » qui n'est qu'un paquet virtuel
N: Aucun paquet n'a été trouvé
x@x-AOA110:~$
x@x-AOA110:~$ sudo apt-get install pepperflashplugin-nonfree
[sudo] password
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet pepperflashplugin-nonfree n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
E: Le paquet « pepperflashplugin-nonfree » n'a pas de version susceptible d'être installée
x@x-AOA110:~$

What is the output of the following commands
sudo updatedb
locate libpep

>> x@x-AOA110:~$ sudo updatedb
x@x-AOA110:~$
(nothing happened)

>> x@x-AOA110:~$ locate libpep
/usr/lib/pepflashplugin-installer/libpepflashplayer.so
x@x-AOA110:~$

Can you start you web browser(s) and navigate to
http://www.adobe.com/software/flash/about/
You should see in a box the information "Version information / You have version xxx.xxx.xxx.xxx installed"
What version number do you see?

>> In Firefox, there is no box, and if I go to the page
https://helpx.adobe.com/flash-player.html
(Verify if Flash Player is installed)
I got Your Flash Version = 11.2.202
But there is a test (If you see clouds moving in the animation below, congratulations, you have successfully installed Flash Player!) that proves that I don't have flashplayer anymore on firefox, because I don't see nothing, just a white space.

>> In Chromium
Version information :
You have version 11,2,202,425 installed

>> And I will add on a detail. Both in firefox and in chromium, if I ask about:plugins or chrome:plugins, I get two versions :

Shockwave Flash - Version : 13.1 r2
Nom :    Shockwave Flash
Version :    13.1 r2
Emplacement :    /usr/lib/mozilla/plugins/libfreshwrapper.so
Type :    NPAPI
      Désactiver
Types MIME :    Type MIME    Description    Extensions de fichier
application/x-shockwave-flash    Shockwave Flash    .swf

Adobe Flash Player - Version : 11.2 r202
Shockwave Flash 11.2 r202
Nom :    Shockwave Flash
Version :    11.2 r202
Emplacement :    /usr/lib/flashplugin-installer/libflashplayer.so
Type :    NPAPI
      Désactiver
Types MIME :    Type MIME    Description    Extensions de fichier
application/x-shockwave-flash    Shockwave Flash    .swf
application/futuresplash    FutureSplash Player    .spl

Manfred Hampl (m-hampl) said : #16

I do not know any possibility to have a flashplayer version higher that 11.2.202 in firefox, just Chrome (Chromium) should be able to have release 16.0.0.xxx with the pepperflash plugin.
I do not know why your chromium still shows only 11.2
This might be related that you are running an obsolete release of Ubuntu, and so you most probably have outdated versions of chrome and firefox (which versions are they?).

I do not have any further ideas except switching over to a supported Ubuntu release.

Papouchi (papouchi) said : #17

Manfred Hampl proposed the following answer:
I do not know any possibility to have a flashplayer version higher that 11.2.202 in firefox, just Chrome (Chromium) should be able to have release 16.0.0.xxx with the pepperflash plugin.
I do not know why your chromium still shows only 11.2
This might be related that you are running an obsolete release of Ubuntu, and so you most probably have outdated versions of chrome and firefox (which versions are they?).

>> Chromium
Version 34.0.1847.116 Ubuntu 12.10 (260972)

>> A propos de Mozilla Firefox
Firefox 35.0

But anyway, you have make me think about something : I've removed the freshplayerplugin and now I have again the sound and the video in firefox, with the old version of flashplayer.
I will try to purge the pepflashplugin-installer and then to install it one more time, without all the mistakes that I've made the first time, maybe it will help, and if not, I've did all what I could.

If it works, believe me I will tell you ! Thank you very much for all your answers, it really did help me.

Papouchi (papouchi) said : #18

My problem is solved :-)

Thank you very much Manfred for your help. A very big thank you also to Daniel Richard G., that among other things found what I had forgotten to do :

https://launchpad.net/~skunk/+archive/ubuntu/pepper-flash

(...)
MAKING CHROMIUM USE PEPPER FLASH
Once the pepflashplugin-installer package is installed, you will need to configure Chromium to use the plugin. Open /etc/chromium-browser/default in a text editor and add the following line to the end of the file:
    . /usr/lib/pepflashplugin-installer/pepflashplayer.sh
(I.e. a period, then a space, then the filepath.)
Restart Chromium, and load the chrome://plugins page to verify that the plugin is active. (Note that if you see a Flash plugin with a version of 11.2 or lower, then that is an old, non-PPAPI version of Flash. A current version of Pepper Flash will be 11.7 or higher.)

And so now, on the page http://www.adobe.com/software/flash/about/, I got :
You have version 16,0,0,305 installed !!!

Ubuntu 12.10 is not dead yet :-)

Manfred Hampl (m-hampl) said : #19

Ubuntu 12.10 is not fully dead, but in coma ;-)

You have to be aware that you do not get any security updates any more, not even for critical vulnerabilities.
So your system might be vulnerable to the heartbleed, shellshock, ghost, ... bugs (any vulnerability detected within the last 9 months).

Just as an example:
You have Chromium browser version 34.*, meanwhile version 40.* is the current one (or at least 37.* for precise).

So I can only repeat that you should move over to a supported release as soon as feasible.

If you problem with the flashplugin is resolved, please mark this question document as solved by pressing the appropriate button.

Papouchi (papouchi) said : #20

Please, could you mark this question as solved for me ? I can't do it anymore, I've cancelled my account, that was created for this occasion, and so I can't log in anymore... Sorry !

Manfred Hampl (m-hampl) said : #21

You are the only person who is able to close that question - either by using the buttons on https://answers.launchpad.net/ubuntu/+source/pepperflashplugin-nonfree/+question/261710 or by using the link that you receive in the response e-mail.

It is no problem if the question stays open. It will be set to "expired" if it stays open without further answer for two weeks.

Can you help with this problem?

Provide an answer of your own, or ask Papouchi for more information if necessary.

To post a message you must log in.