Launchpad upstream connection for pcre2 is wrong

Asked by John Vandenberg

Question information

English Edit question
Ubuntu pcre2 Edit question
No assignee Edit question
Solved by:
Colin Watson
Last query:
Last reply:
Revision history for this message
Manfred Hampl (m-hampl) said (last edit ):

Sorry to correct you, but posting this in the Launchpad area is wrong.

The link from an Ubuntu package to the upstream project can be changed by everybody, so please do this yourself
Just open and press the red button besides the wrong upstream connection to remove it.
Or open the wrong target and remove the links from there,

Background of this wrong linking probably is the following:
An upstream link can only be made to a project that has been registered in Lauchpad.
There is no project "pcre2" in launchpad, just a "jpcre2" project.
Apparently somebody created that wrong upstream link, and now it is carried forward from one Ubuntu release to the next.

Revision history for this message
John Vandenberg (jayvdb) said :

I dont seem to have that red button.

I can see where it should be based on the image on , but it doesnt appear for me. Not on pcre2, and not on either.

Maybe it is related to my account having karma 0? has comments from 2011 saying karma isn't used for permissions. :/

Revision history for this message
Best Colin Watson (cjwatson) said :

Things have changed a bit since 2011; Launchpad does take whether you have a track record of doing things in Launchpad into account for some things, because simply allowing anyone on the internet to sign up and immediately change things isn't very sustainable.

I've removed the incorrect links. I haven't created new ones, because nobody has felt the need to set up a Launchpad project for pcre2 yet, but if somebody wants to do that then it should be straightforward enough to add new links.

Revision history for this message
John Vandenberg (jayvdb) said :

Thanks Colin Watson, that solved my question.

Revision history for this message
John Vandenberg (jayvdb) said :

Thanks Colin. Is there some page documenting the permission structure? I may have karma 0, but I have been here since 2009, and raised a bunch of bugs.

Also IMO there is a rather important usability bug here, as people assume the button to disconnect exists for everyone. I think it should exist, and be greyed out, ideally with a title which indicates why it is disabled for the user, and linking through to the permissions docs.