Ubuntu

Pbuilder stop to dh_shlibdeps

Asked by Florent Delayen on 2010-12-05

Hi

I try to package and submit my first app to launchpad, and to build it with pbuilder too (the same error appears on pbuilder and on the launchpad builder)

With dpkg-buildpackage, the dh_shlibdps is ok, there are some warnings but it does not really matter, and my package is ok.

With pbuilder, I can see this:

****************************
dpkg-shlibdeps: error: couldn't find library libgtk-x11-2.0.so.0 needed by debian/schedio/usr/share/schedio/plugin/lancement périodique (ELF format: 'elf64-x86-64'; RPATH: '').
Note: libraries are not searched in other binary packages that do not have any shlibs or symbols file.
To help dpkg-shlibdeps find private libraries, you might need to set LD_LIBRARY_PATH.
dh_shlibdeps: dpkg-shlibdeps -Tdebian/schedio.substvars debian/schedio/usr/bin/schedio debian/schedio/usr/share/schedio/window_maker_ncy debian/schedio/usr/share/schedio/window_maker debian/schedio/usr/share/schedio/Default_scheduler debian/schedio/usr/share/schedio/plugin/conflit debian/schedio/usr/share/schedio/plugin/lancement périodique returned exit code 2
dpkg-buildpackage: error: fakeroot debian/rules binary gave error exit status 9
E: Failed autobuilding of package
****************************

My debian/control:
*************************
Source: schedio
Section: utils
Priority: extra
Maintainer: DELAYEN Florent <email address hidden>
Build-Depends: debhelper (>= 7.0.50~)
Standards-Version: 3.8.4
Homepage: https://launchpad.net/schedio

Package: schedio
Architecture: amd64
Depends: libgtk2.0-0 (>=2.0)
Description: Gestion de scripts
 Schedio vous aide à configurer des scripts de façon simple et graphique.
 Il est livré avec plusieurs scripts, dont un lanceur périodique d'applications et un gestionnaire de conflits.
***********************
If somebody knows what I can do...

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu pbuilder Edit question
Assignee:
No assignee Edit question
Solved by:
Florent Delayen
Solved:
2010-12-05
Last query:
2010-12-05
Last reply:
Florent Delayen (tnedel) said : #1

I replace my debian/control with right dependencies:
**************
Source: schedio
Section: utils
Priority: extra
Maintainer: DELAYEN Florent <email address hidden>
Build-Depends: debhelper (>= 7.0.50~)
Standards-Version: 3.8.4
Homepage: https://launchpad.net/schedio

Package: schedio
Architecture: amd64
Depends: libatk1.0-0 (>= 1.29.3), libc6 (>= 2.7), libcairo2 (>= 1.2.4), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.2.1), libgcc1 (>= 1:4.1.1), libgdk-pixbuf2.0-0 (>= 2.21.6), libglib2.0-0 (>= 2.16.0), libgtk2.0-0 (>= 2.10.0), libpango1.0-0 (>= 1.14.0), libpng12-0 (>= 1.2.13-4), libstdc++6 (>= 4.1.1)
Description: Gestion de scripts
 Schedio vous aide à configurer des scripts de façon simple et graphique.
 Il est livré avec plusieurs scripts, dont un lanceur périodique d'applications et un gestionnaire de conflits.
********************

But I have always the same problem

Florent Delayen (tnedel) said : #2

Hi
This debian/control fix the problem:

*********
Source: schedio
Section: utils
Priority: extra
Maintainer: DELAYEN Florent <email address hidden>
Build-Depends: debhelper (>= 7.0.50~),libatk1.0-0 (>= 1.29.3), libc6 (>= 2.7), libcairo2 (>= 1.2.4), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.2.1), libgcc1 (>= 1:4.1.1), libgdk-pixbuf2.0-0 (>= 2.21.6), libglib2.0-0 (>= 2.16.0), libgtk2.0-0 (>= 2.10.0), libpango1.0-0 (>= 1.14.0), libpng12-0 (>= 1.2.13-4), libstdc++6 (>= 4.1.1)
Standards-Version: 3.8.4
Homepage: https://launchpad.net/schedio

Package: schedio
Architecture: amd64
Depends: ${shlibs:Depends}
Description: Gestion de scripts
 Schedio vous aide à configurer des scripts de façon simple et graphique.
 Il est livré avec plusieurs scripts, dont un lanceur périodique d'applications et un gestionnaire de conflits.
****************

Really thanks to me, who find the solution ^^

mycae (mycae) said : #3

I am unsure if this is related, however it might be.

If you are using dh_shlibs, you should be using the automatic libs expansion macros that it provides..
eg:

Depends: ${shlibs:Depends}

you should also be stripping RPATH from your generated libs.

FInally, have you tried setting LD_LIBRARY_PATH like the error suggests? Where is your libgtk-x11-2.0.so.0 anyway?

Florent Delayen (tnedel) said : #4

Yes, but it does not work.
The libgtk-x11-2.0.so.0 is in /usr/lib, and in the package "libgtk2.0-0"
I think that was the build-depends and the package's depends.