Sound not working after upgrade to Xubuntu 21.10

Asked by Steve Fowell

I installed Xubuntu 21.04 (as the only operating system) on my Acer Chromebook CB3-111. Everything was working fine, including the sound. I upgraded to Xubuntu 21.10 as advised and now there is no sound. The Sound application shows that there are no hardware devices so the sound hardware must not have been detected.
To be sure, I reinstalled version 21.04 from scratch and upgraded to 21.10 again and I have the same problem. I had previously installed version 21.10 from scratch and had the same problem so I reverted to 21.04. But I now upgraded to 21.10 as I was directed to do so.
I have today (22/02/22) installed the latest updates for 21.10 but the problem remains.
Something in version 21.10 must have broken what was in version 21.04.
Please investigate.

Question information

English Edit question
Ubuntu pavucontrol Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:

This question was originally filed as bug #1961810.

This question was reopened

Revision history for this message
Erich Eickmeyer (eeickmeyer) said :

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We understand the difficulties you are facing, but it is better to raise problems you are having in the support tracker at if you are uncertain if they are bugs. You can also find help with your problem in the support forum of your local Ubuntu community or asking at or For help on reporting bugs, see

Revision history for this message
Best actionparsnip (andrew-woodhead666) said :

If you install Xubuntu 22.04 is it OK? This will be out soon and is LTS.

Revision history for this message
Steve Fowell (srfman) said :

Ok, thanks, I will try 22.04 when I can get it.

But, I can't understand why this issue cannot be a bug in 21.10. Works in 21.04 but not in 21.10. That is a nailed on bug in my world.

Would you be able to throw some light on why Erich thinks that it isn't a bug?

Also, sorry, but I don't understand why there is only a "This Solved My Problem" button below. Although I will have to click it to send this message, my problem clearly hasn't been solved yet!


Revision history for this message
Manfred Hampl (m-hampl) said (last edit ):

1. Why probably not a bug?
A bug is a program error that affects every user (or at least a big group of them).
Your problem seems to be caused by a configuration error on you system, which is something different.

2. "This Solved my Problem" relates to a comment by somebody else.
If you want to enter more information, there are other buttons at the end of the page, namely "I Still Need an Answer", "Just Add a Comment" and "Problem Solved"

3. If you have problems with sound, then you should follow

Revision history for this message
Steve Fowell (srfman) said :

Sorry Manfred but this makes no sense at all. If this issue only affects Acer Chromebook CB3-111 then it isn't going to affect every user. It will only affect CB3-111 users. But that makes it no less of a bug. The sound works fine in version 21.04 but does not work in version 21.10. If I revert to 21.04 it works. No matter how I install 21.10 it doesn't. It might be a configuration issue but that issue must have been introduced into the distribution. Hence a bug. How can it possibly be related to something that I might have done?

I have already tried some troubleshooting from information I found on other sites but nothing has worked. If my problem isn't going to be accepted as a bug then perhaps the developers could assist by explaining what they have changed in the 21.10 distribution that could affect the sound.

Ok, I think I understand now why there was only a "This solved my problem" button previously. I can see I have other buttons below now.


Revision history for this message
Manfred Hampl (m-hampl) said :

Repeating item 3 of my comment #4:

If you have problems with sound, then you should follow

Revision history for this message
Steve Fowell (srfman) said :

I have now found and installed Xubuntu 22.04 and the sound now works.

So, over the last few weeks I have separately installed, from scratch, in exactly the same way, versions 21.04, 21.10 and 22.04. The sound works in both versions 21.04 and 22.04. It does not work in version 21.10.

I am pleased to have found that the sound works in this latest release so my problem is now solved. However, I stick by my statement that the sound not working in version 21.10 must be a bug as the sound did work in version 21.04.

Revision history for this message
Steve Fowell (srfman) said :

Thanks actionparsnip, that solved my question.