partimage amd64

Asked by Oliver Rompcik

Hi guys,

is there any reason for partimage not beeing available on amd64? I can't see any big differences to the original debian package, which compiles successfully under 64bit (and other platforms).

Question information

English Edit question
Ubuntu partimage Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Arnaudus (a-lerouzic) said :

Bug #1168 is a very old bug that shows that partimage used to be broken for AMD 64. Bug #19124 is identical, except that it is labelled "Fix released". The problem is thus supposed to be fixed since 2007.

What version of Ubuntu are you using?

Revision history for this message
Arnaudus (a-lerouzic) said :

(Sorry, I was too fast. The "fix" of bug #19124 just consists in providing the 32-bits package on 64-bit architectures. Ths problem does not appear when compiling, but when executing. Do you have any information whether it has been fixed upstream?)

Revision history for this message
Oliver Rompcik (oliver-rompcik) said :

I used partimage 0.6.7-1 from Debian Lenny, source compiles well under amd64 and binary executes without further problems. (Ubuntu version is Jaunty.)

luke@tatooine:/home/luke/src# file /usr/sbin/partimage
/usr/sbin/partimage: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.8, stripped
luke@tatooine:/home/luke/src# ldd /usr/sbin/partimage => (0x00007fff7fbff000) => /lib/ (0x00007f127762c000) => /lib/ (0x00007f12773f4000) => /lib/ (0x00007f12771f0000) => /lib/ (0x00007f1276fe4000) => /lib/ (0x00007f1276dcc000) => /usr/lib/ (0x00007f1276bb5000) => /lib/ (0x00007f12769a4000) => /lib/ (0x00007f1276788000) => /lib/ (0x00007f12763ff000) => /lib/ (0x00007f12761b0000) => /usr/lib/ (0x00007f1275ea3000) => /lib/ (0x00007f1275c1e000) => /lib/ (0x00007f1275a06000) => /lib/ (0x00007f1275694000)
        /lib64/ (0x00007f1277977000)

Revision history for this message
Steve (stupendoussteve-deactivatedaccount) said :

This package was fixed a while ago, and should have been built for Jaunty (the bug saying so was marked Fix Released). It looks like deleting the old, messed up version from the repos caused newer ones not to be built either.

I have rebuilt this package in my ppa, it is exactly the same except the version number is different and the changelog was updated (the version number was an accident, but if they update the ubuntu package ever their version will gain presidence). The package is building right at this moment, and should be up within the hour. You're free to try it out but of course there are no warranties. Hopefully they will get their version fixed soon! :)

Revision history for this message
Oliver Rompcik (oliver-rompcik) said :

Still not in the official repo, neither in Jaunty, nor the coming Karmic. Whats up?

I've thought that it is shown that partimage compiles and runs well on the amd64 platform. Where are your packages?

Revision history for this message
woifi (woifi) said :


still no amd64 package for partimage.. can you please build one at least for lucid?

thanks in advance!

Revision history for this message
Fabián Rodríguez (magicfab) said :

woifi I just linked this bug:

Please go there and subscribe to it, also mark it as affecting you (using the special link, not the comments)

Can you help with this problem?

Provide an answer of your own, or ask Oliver Rompcik for more information if necessary.

To post a message you must log in.