Package not found by apt-get install, even after updating

Asked by Rose Jeeves on 2017-09-05

I can see the parsnp package on here, but when I try to install using apt-get install or look for it using apt-cache search parsnp it is not found. I have updated and I have checked that the universe repository has been added. Any suggestions would be greatly appreciated.
Thanks
Rose

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu parsnp Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2017-09-06
Last query:
2017-09-06
Last reply:
2017-09-06
Manfred Hampl (m-hampl) said : #1

For diagnostic purposes please provide the output of the following commands:

uname -a
lsb_release -crid
sudo apt-get update

Rose Jeeves (rosejeeves) said : #2

hi,
Thanks for looking at this.
uname -a :
 UTC 2017 x86_64 x86_64 x86_64 GNU/LinuxUTC 2017 x86_64 x86_64 x86_64 GNU/Linux

lsb_release -crid:
Distributor ID: Ubuntu
Description: Ubuntu 16.04.2 LTS
Release: 16.04
Codename: xenial

sudo apt-get update:
Ign:1 http://download.opensuse.org/repositories/home:/evilissimo:/ubuntu:/16.04/xUbuntu_16.04 InRelease
Hit:2 http://download.opensuse.org/repositories/home:/evilissimo:/ubuntu:/16.04/xUbuntu_16.04 Release
Get:3 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Get:5 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages [355 kB]
Get:6 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages [332 kB]
Get:7 http://security.ubuntu.com/ubuntu xenial-security/main Translation-en [155 kB]
Hit:8 https://packages.cisofy.com/community/lynis/deb xenial InRelease
Get:9 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 Packages [167 kB]
Get:10 http://security.ubuntu.com/ubuntu xenial-security/universe i386 Packages [146 kB]
Get:11 http://security.ubuntu.com/ubuntu xenial-security/universe Translation-en [87.2 kB]
Hit:12 http://mirror.phe.gov.uk/archive.ubuntu.com/ubuntu xenial InRelease
Hit:13 http://mirror.phe.gov.uk/archive.ubuntu.com/ubuntu xenial-updates InRelease
Hit:14 http://mirror.phe.gov.uk/archive.ubuntu.com/ubuntu xenial-backports InRelease
Fetched 1,344 kB in 1s (1,344 kB/s)
Reading package lists... Done

Best Manfred Hampl (m-hampl) said : #3

If you look at https://launchpad.net/ubuntu/+source/parsnp you should be able to see that Ubuntu packages with parsnp are available only for Ubuntu 17.04 (zesty) and 17.10 (artful, currently in development), but your system is Ubuntu 16.04 (xenial).

It may be possible to install the package for Ubuntu 17.04 on a 16.04 system, but I am not sure whether all dependencies can be met on a 16.04 system.

Rose Jeeves (rosejeeves) said : #4

Thanks Manfred Hampl, that solved my question.