What's wrong with VLC Player and an m4v file? No reaction from VLC

Asked by Adalbert Hanßen on 2019-03-04

This question pertains to Xubuntu 16.04.6 LTS (64 Bit), currently with Linux kernel 4.4.0-142-generic x86_64.
It also pertains to VLC Media Player Version 2.2.2 Weatherwax 2017-08-08T18:59:52.

A friend recorded a video for me in which the speaker speaks terribly fast in a foreign language (for me). Therefore I can not understand this technical video.

Since I had the experience from podcasts played on my smart phone, it is often helpful, to run foreign language recordings at a reduced speed. Therefore I got the idea to try this with a video. I gave it a first try with a speech of the French president (as mp4 file) and that worked fine. Unfortunately the video I want to understand this time, can not be easily downloaded. I just get an html file and somewhere coded in it probably is the source to be streamed, perhaps this is the essence of what I want to download: http://www.wolfram.com/broadcast/video.php?v=2595).

First I tried to catch the replay of this video from my own computer by issuing the command

ffmpeg -f alsa -i pulse -f x11grab -r 25 -s 1280x720 -i :0.0+0,24 -acodec pcm_s16le -vcodec libx264 -threads 0 output.mkv

and then start the replay. I only got a file which had no audio part! (I found a similar example of an ffmpeg-command on the internet but had to drop the parameter "-vpre lossless_ultrafast" from the original example, because it was rejected). After issuing the command I had started replaying the video and my recording showed everything I did to start the video until I stopping it. Unfortunately without sound, which was my main objective in order to replay it with VLC with 0,67 speed.

Then I asked help from a colleague who is very smart in multimedia issues. He did it with an apple computer and he first sent me a video file in a proprietary Apple format, which VLC definitely can't digest. I sent him a screenshot of the formats which VLC can digest and asked him for help again and then he sent me a m4v file.

When I try to open the m4v file with a double click, parole comes up. Then an error of a missing text/html decoder shows up accompanied by the suggestion to have it installed. But it did not. But I don't know if parole can replay a video with reduced speed.

Therefore I started VLC by hand and opened the video file in question in format *.m4v, but nothing happened. Not even an error message "this file format is unknown to VLC" or the like!

What's wrong here?

I also had tried - unfortunately in vain - to open the video directly from its original source on the internet. If I would right-click on the play button, it would save a html file.

The dialog for opening a medium as a stream asks for something as an avi stream, but here the URL ends as video.php?c=453&v=2595 and if I provide this (complete) URL, nothing happens.

Is it possible to make a screen recording with VLC (and how has this to be done then)? That would be great bypassing the necessity to really understand the thousands of lines description of how to use ffmpeg! Of course, a living example how to record a screen replay ans a video file with ffmpeg such that the result can later be replayed at less speed would also be very welcome.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu parole Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2019-03-04
Last query:
2019-03-04
Last reply:
2019-03-04

what is the output of:

lsb_release -a; uname -a; apt-cache policy vlc

Thanks

Best Manfred Hampl (m-hampl) said : #2

it seems that this Problem was caused by a broken video file (probably incomplete download), see https://answers.launchpad.net/ubuntu/+source/parole/+question/678928

Adalbert Hanßen (melolontha) said : #3

@#1: The ouptout of lsb_release is:

$ lsb_release -a; uname -a; apt-cache policy vlc
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.6 LTS
Release: 16.04
Codename: xenial
Linux username 4.4.0-142-generic #168-Ubuntu SMP Wed Jan 16 21:00:45 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
vlc:
  Installiert: 2.2.2-5ubuntu0.16.04.4
  Installationskandidat: 2.2.2-5ubuntu0.16.04.4
  Versionstabelle:
 *** 2.2.2-5ubuntu0.16.04.4 500
        500 http://de.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages
        500 http://de.archive.ubuntu.com/ubuntu xenial-security/universe amd64 Packages
        100 /var/lib/dpkg/status
     2.2.2-5 500
        500 http://de.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages

Adalbert Hanßen (melolontha) said : #4

Thanks Manfred Hampl, that solved my question.