Can the LTS package be bumped to 1.36.8?

Asked by Filip Navara on 2018-04-01

Pango 1.36.8 added some useful APIs that we consume as part of libgdiplus. Since all our CI machines run on Ubuntu Trusty LTS we are currently stuck with version 1.36.3. Could the package be updated to a newer patch level? Even Debian jessie, the oldest supported one, has version 1.36.8.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu pango1.0 Edit question
Assignee:
No assignee Edit question
Last query:
2018-04-01
Last reply:
2018-04-01

If you report a bug and the bug and security fixes are significant then the package will be updated sooner rather than later.

The packages in Ubuntu are infrequently updated especially in the LTS releases. Stability is champion in Ubuntu.

There may be a PPA.

Seems to be tied to the Gnome version you are running so you'd need to upgrade all of that to get it.

Bionic has 1.40 so you could upgrade to Ubuntu 18.04 and get the version. Bionic is currently unstable but is released in 3 weeks or so.

You could use the Gnome Staging PPA but this comes with the usual caveats of a PPA

https://launchpad.net/~gnome3-team/+archive/ubuntu/gnome3-staging

Can you help with this problem?

Provide an answer of your own, or ask Filip Navara for more information if necessary.

To post a message you must log in.