1.0.4-1.1+deb8u1build0.16.04.1 has broken my python pam module, fails on: from httplib2 import Http

Asked by Michael Pardee on 2020-10-22

I glanced at the diff but it wasn't immediately obvious - why does this security update break importing httplib2 ? Other more standard imports like sys, os, datetime, don't seem to be a problem.

Traceback (most recent call last):
File "/lib/security/pam_pacauth.py", line 18, in <module>
     from httplib2 import Http
 ImportError: No module named httplib2

Here's line 18:

from httplib2 import Http

I have reverted to the old libpam-python_1.0.4-1_amd64.deb for now but is this a bug or do I need to adjust my code?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu pam-python Edit question
Assignee:
No assignee Edit question
Solved by:
Michael Pardee
Solved:
2020-11-03
Last query:
2020-11-03
Last reply:

fixed in 1.0.4-1.1+deb8u1ubuntu0.1