how to add missing pacparser package/PPA link

Asked by Dimitry Verkholashin on 2011-07-27

The main reason why I want to add pacparser is because it supports python, and this tool appears to be useful for gnome's network-proxy (this way I can define popular targets and more...).

Based on *pacparser* package information on launchpad, pacparser is marked as The Lucid Lynx (supported). However, I am having trouble finding pacparser and the underlying packages among other packages after adding the following line to Apt Sources List:

deb-src http://us.archive.ubuntu.com/ubuntu/ lucid universe

I tried variations of this URI link and there must be something incorrect parameter in the URI I am supplying to apt, or, perhaps, something is really blocking me and I am not understanding something correctly. Anyhow, there is nothing that states this package does not work on Lucid, and I don't mind compiling the package from source, but not in a form it exists on Google wiki. Can you kindly point me in the right direction for PPA and Key ID to install this package.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu pacparser Edit question
Assignee:
No assignee Edit question
Last query:
2011-07-27
Last reply:
2011-07-28
Manfred Hampl (m-hampl) said : #1

Do I interpret your question correct that you are running a lucid system (execute "lsb_release -a" in a terminal)?

Launchpad seems to have an inconsistency and a dependency problem in pacparser on lucid (and maverick) that have not been resolved for more than a year, see https://launchpad.net/ubuntu/lucid/i386/python-pacparser

The errors seem to be resolved only in the natty and oneiric versions.

I do not know an easy and straightforward way how you can install pacparser on your system. Just some ideas:

1. Maybe downloading the .deb files and manually installing can work:
https://launchpad.net/ubuntu/lucid/i386/python-pacparser/1.0.9-2 or https://launchpad.net/ubuntu/lucid/ia64/python-pacparser/1.0.9-2
you might also need https://launchpad.net/ubuntu/lucid/i386/libmozjs0d/1.8.1.16+nobinonly-0ubuntu1 or https://launchpad.net/ubuntu/lucid/ia64/libmozjs0d/1.8.1.16+nobinonly-0ubuntu1 and others

2. the source is available on https://launchpad.net/ubuntu/lucid/+source/pacparser
for building the package yourself you might also need libmozjs-dev and libmozjs0d and maybe some more

Thank you for providing the links. Here is the output from lsb_release -a:

LSB Version:
core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch:cxx-3.0-ia32:cxx-3.0-noarch:cxx-3.1-ia32:cxx-3.1-noarch:cxx-3.2-ia32:cxx-3.2-noarch:cxx-4.0-ia32:cxx-4.0-noarch:desktop-3.1-ia32:desktop-3.1-noarch:desktop-3.2-ia32:desktop-3.2-noarch:desktop-4.0-ia32:desktop-4.0-noarch:graphics-2.0-ia32:graphics-2.0-noarch:graphics-3.0-ia32:graphics-3.0-noarch:graphics-3.1-ia32:graphics-3.1-noarch:graphics-3.2-ia32:graphics-3.2-noarch:graphics-4.0-ia32:graphics-4.0-noarch:printing-3.2-ia32:printing-3.2-noarch:printing-4.0-ia32:printing-4.0-noarch:qt4-3.1-ia32:qt4-3.1-noarch
Distributor ID: Ubuntu
Description: Ubuntu 10.04.3 LTS
Release: 10.04
Codename: lucid

What I am looking for is the link to PPA with Key ID (possibly experimental
PPA) from which I can download pacparser and the packages it depends on, but
so far it appears that no one is working on pacparser code (it's pretty much
done -- the way I understand it, Python or C is used to parse Java/Java
script code).

Since I have 10.04 LTS, first solution is fine as long as the packages can
be authenticated. However, there are inherent issues with sending unsigned
packages even over encrypted connection. I suppose the key here is that the
packages are signed and I can get them through Synaptic-Aptitude/packagekit.
In either case I have apt backend. The same holds truth for the second
solution. That is why I am asking whether if there is upstream PPA available
for download. Just searching for pacparser yielded results for flavors other
than Lucid.

Another solution would be to download the code from google wiki, but they
are using weak hash and there is no reference to PGP key used to sign the
zips. This chicken-egg situation reminds me of Dell firmware packages, but
at least I can them authenticated directly from Dell. Finding their key is
easy. The egg problem is resolved by modifying Python2.5 to work with
Python2.6.

When I actually browse the repositories, I can find find files describing
hashsums and other information for the pacparser. There must be something
incorrect in URI I am specifying. It would be kinds of Canonical/Ubuntu to
provide insight and instructions how install these packages. Of course the
disclaimer might be necessary in case some of them cannot be uninstalled
later, but if you know how to use 'find/locate', you should be able to
unstall it anyways.

On Wed, Jul 27, 2011 at 12:16 AM, Manfred Hampl <
<email address hidden>> wrote:

> Your question #166101 on pacparser in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/pacparser/+question/166101
>
> Status: Open => Answered
>
> Manfred Hampl proposed the following answer:
> Do I interpret your question correct that you are running a lucid system
> (execute "lsb_release -a" in a terminal)?
>
> Launchpad seems to have an inconsistency and a dependency problem in
> pacparser on lucid (and maverick) that have not been resolved for more
> than a year, see https://launchpad.net/ubuntu/lucid/i386/python-
> pacparser
>
> The errors seem to be resolved only in the natty and oneiric versions.
>
> I do not know an easy and straightforward way how you can install
> pacparser on your system. Just some ideas:
>
> 1. Maybe downloading the .deb files and manually installing can work:
> https://launchpad.net/ubuntu/lucid/i386/python-pacparser/1.0.9-2 or
> https://launchpad.net/ubuntu/lucid/ia64/python-pacparser/1.0.9-2
> you might also need
> https://launchpad.net/ubuntu/lucid/i386/libmozjs0d/1.8.1.16+nobinonly-0ubuntu1or
> https://launchpad.net/ubuntu/lucid/ia64/libmozjs0d/1.8.1.16+nobinonly-0ubuntu1and others
>
> 2. the source is available on
> https://launchpad.net/ubuntu/lucid/+source/pacparser
> for building the package yourself you might also need libmozjs-dev and
> libmozjs0d and maybe some more
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/ubuntu/+source/pacparser/+question/166101/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/pacparser/+question/166101
>
> You received this question notification because you asked the question.
>

Manfred Hampl (m-hampl) said : #3

As far as I can see there is no ready-built package with pacparser available for lucid anywhere on the ubuntu or launchpad servers, also not in any PPA. There are only versions for natty and oneiric depending on python>=2.7

The pacparser version on debian.org depend on python>=2.6, so maybe that is installable and functioning on your lucid system.

Disclaimer: mixing repositories from Ubuntu and Debian is not recommended.

To verify if the debian package is installable you could download the .deb package from http://packages.debian.org/squeeze/python-pacparser (or http://packages.debian.org/sid/python-pacparser or http://packages.debian.org/wheezy/python-pacparser) and then check if all dependecies are fulfilled with the command
dpkg --simulate -i python-pacparser_{version}_{arch}.deb

P.S.: My private remark: I would not be so sceptic about (un)authenticated packages.

Can you help with this problem?

Provide an answer of your own, or ask Dimitry Verkholashin for more information if necessary.

To post a message you must log in.