Upgrade to 2.0

Asked by Ben Fu on 2019-04-22

Is there a way we could upgrade the version to 2.0? The pcs package requires a version of pacemaker that is greater than or equal to 2.0, and there is already a debian version packaged for v2.

https://pkgs.org/download/pacemaker

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu pacemaker Edit question
Assignee:
No assignee Edit question
Last query:
2019-04-22
Last reply:
2019-04-23

I suggest you report a bug. If the bug and security fixes are significant then the package will be updated sooner rather than later

Ben Fu (ben-fu1) said : #2

Thanks, I just filed a bug for the version upgrade. Ubuntu users can't really install the pcs package as it requires pacemaker>=2.0 and corosync >=3.0, which is not in any of the ubuntu repos. Please let me know if you need any help with testing and packaging pacemaker or corosync, as I'll be glad to help in any way. For reference here are the upstream repos and their latest releases:

https://github.com/ClusterLabs/pacemaker
https://github.com/ClusterLabs/pcs
https://github.com/corosync/corosync

Can you help with this problem?

Provide an answer of your own, or ask Ben Fu for more information if necessary.

To post a message you must log in.