Cannot install owncloud-client in ubuntu 20.10 (groovy gorilla)

Asked by Herbert Post on 2020-10-22

Package is not available. (also not on owncloud website)
It is not possible to install the 20.04 version.
This package is crucial to me.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu owncloud-client Edit question
Assignee:
No assignee Edit question
Solved by:
Herbert Post
Solved:
2020-10-24
Last query:
2020-10-24
Last reply:
2020-10-22

https://launchpad.net/ubuntu/+source/owncloud-client/+changelog
It's unmaintained in Debian so has been removed from the official repo

I found this. You could use the 20.04 folder as shown in this guide. It should install OK. I'd imagine the deps are similar
https://www.osradar.com/install-owncloud-desktop-client-ubuntu-20-04/

Manfred Hampl (m-hampl) said : #3

I guess this will not work, because libicu66 is not available in groovy (has been replaced by libicu67)

Why did you upgrade to groovy before investigating whether the software that you use is available there?

You might try contacting owncloud.com and ask them about a version that works with Ubuntu 20.10

Herbert Post (roberine) said : #4

I am still on 20.04
I tested in a VM
I will ask owncloud for an updated version.

Herbert Post (roberine) said : #5

Problem solved.
I just needed to install this 20.04 package: libicu66_66.1-2ubuntu2_amd64.deb
which I dowloaded from https://packages.ubuntu.com/
After this installing the package as per instructions on
https://software.opensuse.org/download/package?project=isv:ownCloud:desktop&package=owncloud-client
went without error.