I cannot install OpenVAS

Asked by caryll on 2017-09-29

Hi All,

Hope someone can help.

I'm new in OpenVAS and I can't seem to install it on Ubuntu 17.04. The error starts in sudo apt-get update with the error

Failed to fetch http://ppa.launchpad.net/mrazavi.openvas/ubuntu/dist/zesty/main/binary-amd64/Packages 404 Not Found.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu openvas Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2017-09-29
Last query:
2017-09-29
Last reply:
2017-09-29
Manfred Hampl (m-hampl) said : #1

I assume that there is an error in the PPA address.
What instructions did you use for adding that PPA?

https://launchpad.net/~mrazavi/+archive/ubuntu/openvas

The PPA only supports Trusty and Xenial and should be removed. Not all PPAs support all releases of Ubuntu.

caryll (caryll) said : #3

Thanks Manfred. I used the

sudo apt-get update -y
sudo apt-get upgrade -y
sudo reboot

sudo apt-get install python-software-properties

which I found on installation instructions of multiple websites found below. By the way I'm on VirtualBox and my image is a fresh install.

Tried to open the site in my browser and I get 404 and permission denied.

https://www.vultr.com/docs/how-to-install-openvas-vulnerability-scanner-on-ubuntu-16-04
http://olivermarshall.net/how-to-install-openvas-9-on-ubuntu-16/
https://launchpad.net/~mrazavi/+archive/ubuntu/openvas
https://hackertarget.com/openvas-9-install-ubuntu-1604/

caryll (caryll) said : #4

Thanks Andrew. Maybe because I'm using Zesty of Ubuntu. Would you know how can I install OpenVAS using Zesty?

caryll (caryll) said : #5

Thanks actionparsnip, that solved my question.

https://launchpad.net/ubuntu/+ppas?name_filter=openvas

Filter the PPA using the drop down to see what releases are supported. If Zesty is supported then check the PPA has openvas for Zesty then add that PPA and it will install.

Is the package not in the default Ubuntu repository?

Apparently not.

Manfred Hampl (m-hampl) said : #8

Remarks:
1. Apparently you have mistyped the PPA address "ppa:mrazavi.openvas" instead of "ppa:mrazavi/openvas", and this now leads to error messages (but also with correct naming that PPA does not help for zesty).
2. In a quick search on the Ubuntu repository sources and PPAs I did not find any openvas package for Ubuntu zesty. So you would have to apply tricks (with installing a package designed for a different Ubuntu release) or revert to an older Ubuntu release for which an openvas package is available, or install the development version Ubuntu 17.10 (due for official publication in three weeks' time).

caryll (caryll) said : #9

Thanks Andrew and Manfred.

Is the package not in the default Ubuntu repository? --> I checked on it and I think it's not

I guess I need to revert back to older Ubuntu as I'm not yet a linux pro to do the tricks. :)

Using Xenial will give LTS support until 2021

caryll (caryll) said : #11

Pros and Cons. Thanks Andrew. I think I'll be using Xenial for the OpenVAS. Thanks for your help!