Couldn't find package libssl-dev

Asked by DaClem on 2009-05-10

 I have Ubuntu 7.10

I am getting the above error when entering the following:

peeters@CL01-AR41S:~$ sudo apt-get install libssl-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package libssl-dev
peeters@CL01-AR41S:~$

How can I install the required package, I can see libssl0.9.8 in the Synaptic Package Manager, however how do I obtain and install the required libssl-dev package?

Any help would be appreciated.... thanks!

DaClem

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu openssl Edit question
Assignee:
No assignee Edit question
Last query:
2009-05-10
Last reply:
2009-05-10
Robert Di Gioia (digioiar) said : #1

It appears that the 7.10 repos have been removed. This is in keeping with Ubuntu's stated policy of maintaining support for normal releases for 18 months. Certain releases, denoted as LTS (for long term support), are supported for 3 years. 7.10 is a normal release, support ended on April 18, 2009.

In order to install this package, I think you will need to upgrade to at least Hardy Heron (8.04 LTS), and depending on your situation, it may be better to move to the current release, Jaunty Jackalope (9.04). I've found Jaunty to be very stable.

However, perhaps some others here will be able to provide another option.

Hope this helps.

Change your apt mirror to old-releases.ubuntu.com, this is where the gutsy repos have moved (I do recommend upgrading though).

Can you help with this problem?

Provide an answer of your own, or ask DaClem for more information if necessary.

To post a message you must log in.