Could a libssl1.1-dev please be made for Ubuntu Jammy?

Asked by Jason Perrin

I've noticed that Ubuntu Jammy currently has libssl1.1 and libssl3 packages (makes sense), but when it comes to libssl-dev there's only one version (3.0). This lines up with trying to get everything built on the new version of OpenSSL, but quite a lot of software is not ready for that yet (e.g. only in Ruby 3.1 does it start supporting OpenSSL 3 and 2.7/3.0 that are both in jammy currently couldn't actually be built with the libssl-dev provided).

I also see there is a libssl1.0-dev for bionic (, so there's some kind of precedent for splitting the dev packages and having multiple.

Apologies if this is already planned or I'm asking this too early, I just didn't want to get closer to the feature freeze for jammy or something and have it get stuck. Thanks and let me know if I can help or anything!

Question information

English Edit question
Ubuntu openssl Edit question
No assignee Edit question
Solved by:
Manfred Hampl
Last query:
Last reply:
Revision history for this message
Manfred Hampl (m-hampl) said :

The libssl version 1.1 packages for jammy have already been superseded by version 3.
I do not see any libssl1.1 package for jammy any more, see

What exactly are you missing?
What exactly do you suggest?

Revision history for this message
Jason Perrin (jvperrin) said :

Ah interesting, I didn't see that page before. I was looking at the built packages through, for instance:

I can also confirm that I can install both of these versions alongside each other on a jammy host for instance, and that the libssl1.1 package does indeed provide the runtime .so files needed. From those packages I thought that libssl1.1 was still available, but maybe it's a leftover artifact from previous builds before version 3 superseded it?

Anyway, the core of my request is that a lot of software doesn't yet support OpenSSL 3.0, so I think having both 1.1 and 3.0 available in jammy would be very useful to make the transition to the newer version more smooth. This already exists for the runtime packages (libssl1.1 and libssl3), but for development packages there's only one (libssl-dev on 3.0) which makes it hard to build things such as Ruby 2.7/3.0 that don't have support for the very recently released OpenSSL 3.0.

Revision history for this message
Best Manfred Hampl (m-hampl) said :
#3 is only an information page and its contents may lag behind, especially when packages are removed during development of a new release.

Apparently currently the availability and dependency of the various packages for jammy is inconsistent and broken.
see e.g. the failed builds in
I assume that there is the aim to solve the problems (e.g. with ruby) before publication date of Ubuntu 22.04. I hope the developers are already working on it and that they will soon find a solution.

If you think that it is inevitable to re-add libssl1.1 packages to jammy, then you might create a bug report with sufficient justification why that would be necessary and how that could be implemented.

Revision history for this message
Jason Perrin (jvperrin) said (last edit ):

Thanks Manfred Hampl, that answers my question!