Do the packages in LTS releases get updated?

Asked by Kris Willis on 2008-08-13

The current version of OpenSSL available in the 6.06 LTS repos, 0.9.8a, contains a specific bug that affects the encryption for PayPals "Encrypted Website Payments" (EWP) system. I believe this bug was resolved in 0.9.8c. Do the packages ever get updated in previous distro releases?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu openssl Edit question
Assignee:
No assignee Edit question
Last query:
2008-08-13
Last reply:
2008-10-21
Andy Loughran (andylockran) said : #1

Yes, Ubuntu 6.06 will be updated til 2011, with security updates.

Ubuntu 8.04 is the latest LTS release - which will be supported til 2013 with security updates.

If you want to update, use update-manager to bring your currently LTS release up to date, or see:

http://www.ubuntu.com/getubuntu/upgrading

Ramón Rocha (ramon.rocha) said : #2

Also, if you want newer versions for non-bug or non-security changes (such as new features), you can enable the backports repository.

https://help.ubuntu.com/community/UbuntuBackports

Can you help with this problem?

Provide an answer of your own, or ask Kris Willis for more information if necessary.

To post a message you must log in.