running ssh on start up

Asked by gurugdas on 2009-09-19

sudo /etc/init.d/ssh restart
   i need to run this command in the terminal after every startup in order to connect to linux remotely from xp machine over the internet using freenx client.

     is it possible to avoid typing that command everytime i log in?

    pls.help

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu openssh Edit question
Assignee:
No assignee Edit question
Last query:
2009-09-20
Last reply:
2009-09-20
gurugdas (ggd-rns) said : #1

I ALSO needed that i get some sort of indication when a person connects to my jaunty machine over the internet....some display or 2 cursors etc..if possible .

   rt.now as the case is i can come to know only from the system monitor processes ...where nx node is listed as a process while somebody is connected to my pc..

sudo apt-get install bum; gksudo bum

Make sure ssh is ticked to run at startup

Bit hacky but you can run:

gksudo gedit /etc/rc.local

and add:

/etc/init.d/ssh restart

in the gap above the line that says:

exit 0

Save the new file, close gedit and reboot to test

gurugdas (ggd-rns) said : #3

i did one thing before i got your mail and it seems to work although i will have to double check:

system>administration>services>unlock>password>ssh

     and then rebooted the jaunty

    and then just connected from xp machine which is just beside the jaunty but has an independent internet connection...

      and the freenx client connected fine w/o my having to give any command in jaunty terminal

       and i do not have ssh in the startup apps. also...still it connected

       and the 2 pcs (xp & jaunty) share the same MONITOR ,MOUSE,KEYBOARD.. so the mouse can be working with only one pc at one time ..so i was unable to see the effect on jaunty when i connected from wp .....

       hope what i said makes some sense ...
                        do I need do anything else.. i 'll be glad to accept

gurugdas (ggd-rns) said : #4

on the remote pc i do not see the graphical windows of running applications
i.e.i am not able to see in remote xp machine the winamp window running in
jaunty

On Sat, Sep 19, 2009 at 8:46 PM, gurugdas <
<email address hidden>> wrote:

> Your question #83248 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/83248
>
> Status: Answered => Open
>
> You are still having a problem:
> i did one thing before i got your mail and it seems to work although i
> will have to double check:
>
> system>administration>services>unlock>password>ssh
>
> and then rebooted the jaunty
>
> and then just connected from xp machine which is just beside the
> jaunty but has an independent internet connection...
>
> and the freenx client connected fine w/o my having to give any
> command in jaunty terminal
>
> and i do not have ssh in the startup apps. also...still it
> connected
>
> and the 2 pcs (xp & jaunty) share the same MONITOR
> ,MOUSE,KEYBOARD.. so the mouse can be working with only one pc at one
> time ..so i was unable to see the effect on jaunty when i connected
> from wp .....
>
> hope what i said makes some sense ...
> do I need do anything else.. i 'll be glad to accept
>
> --
> You received this question notification because you are a direct
> subscriber of the question.
>

Luky Winarto (luckyborneo) said : #5

Hi gurugdas,

Have you installed openssh-server on your ubuntu? Try to install it.
$ sudo apt-get install openssh-server

Your ssh port will be 22 by default. Have a nice try..
-Luky-

You can use x forwarding. This is default enabled in openssh-server

if you connect with

ssh -X user@server

you can run graphical apps, they will run on the remote system but be shown on the client display. You can achieve this in windows by installing and running xming and installing putty then running

putty -X user@server

You will find a lot of the time, viewing the entire desktop is very overkill as many apps have web interfaces so you dont have to strangle your network by streaming a full desktop

gurugdas (ggd-rns) said : #7

i already have opensshserver installed .
  actionparsnip i need to have a more simpler guidance .
i can see the apps. graphically in the client pc. ,that is fine ..what next?

If the client PC is Linux based you can run:

ssh -X username@server

When you run gui apps, they will appear on the local system. There is a command called xmove which can then move the app from the local x server o the one on your system buty ive never done this before.

http://pwet.fr/man/linux/commandes/xmove

If the client PC is Linux based you can run:

ssh -X username@server

When you run gui apps, they will appear on the local system. There is a command called xmove which can then move the app from the local x server o the one on your system buty ive never done this before.

http://pwet.fr/man/linux/commandes/xmove

Can you help with this problem?

Provide an answer of your own, or ask gurugdas for more information if necessary.

To post a message you must log in.