ssl library deb file

Asked by Luke A. Perkins on 2019-06-12

I am having a problem with building OpenSSH 7.6p1 because I am missing an SSL library.
Can someone tell me or show me the "apt-get" dependencies required to configure and compile the source?

I am running 18.4.02 LTS (bionic-updates) trying to compile OpenSSH 7.6p1 from the Canocal git "origin/ubuntu/bionic-updates".

The error is as follows:
 checking for openssl/opensslv.h... no
configure: error: *** OpenSSL headers missing - please install first or check config.log ***

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu openssh Edit question
Assignee:
No assignee Edit question
Last query:
2019-06-12
Last reply:
2019-06-12
Manfred Hampl (m-hampl) said : #1

The command to install all packages required for building that package is

apt-get build-dep openssh

(The package really missing in your case probably is libssl1.0-dev)

Can you help with this problem?

Provide an answer of your own, or ask Luke A. Perkins for more information if necessary.

To post a message you must log in.