can't use ssh nor unison WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!

Asked by dumpa on 2008-09-23

Hi,
I'm trying to connect with ssh to the computer in my office (ubuntu hardy) from the computer at home (also hardy).
I haven't been able.

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that the RSA host key has just been changed.
The fingerprint for the RSA key sent by the remote host is
XXXX
Please contact your system administrator.
Add correct host key in /home/dumpa/.ssh/known_hosts to get rid of this message.
Offending key in /home/dumpa/.ssh/known_hosts:1
RSA host key for MY-IP has changed and you have requested strict checking.
Host key verification failed.

I updated openssh-server on both computers. I don't know if I need some other package.
When I try to run unison I get Lost Connection With Server.

Is there like a firewall I should turn off or something?
Please can someone point me in the right direction, thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu openssh Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
2008-09-24
Last query:
2008-09-24
Last reply:
2008-09-24

This is a security policy of ssh...

ONLY if you have a dynamic ip ( now changed ) or if you have changed something related your ip or to your remote ip or you have changed/reinstalled Ubuntu or you have done something that you are aware of.

Please, using an editor delete the first line into /home/dumpa/.ssh/known_hosts from terminal type:

gedit /home/dumpa/.ssh/known_hosts

or

nano /home/dumpa/.ssh/known_hosts

or

vi /home/dumpa/.ssh/known_hosts

And retry

Hope this helps

dumpa (dumpita) said : #2

Thanks for the answer.
I got confused , on which computer should I delete that line. Is it on the computer trying to connect, or on the one I'm connecting to? or both?
thanks again

On the computer you get this message...

Hope this helps

dumpa (dumpita) said : #4

It works! Thanks a lot!

dumpa (dumpita) said : #5

Thanks marcobra, that solved my question.