ssh-vulnkey for dapper

Asked by Wouter Horré on 2008-05-16

Is there a version of ssh-vulnkey for dapper?

I have a dapper ssh-server where I would like to check the authorized_keys of the users for vulnerable keys. What are my options?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu openssh Edit question
Assignee:
No assignee Edit question
Solved by:
berg
Solved:
2008-05-16
Last query:
2008-05-16
Last reply:
2008-05-16
Best berg (berg-foss) said : #1

hello Wouter,
see at http://www.ubuntu.com/usn

USN-612-6: OpenVPN regression
USN-612-5: OpenSSH update
USN-612-4: ssl-cert vulnerability CVE-2008-0166
USN-612-3: OpenVPN vulnerability CVE-2008-0166
USN-612-2: OpenSSH vulnerability CVE-2008-0166
USN-612-1: OpenSSL vulnerability

this problem don't affect your version ( dapper 6.06 ), and don't need this check because the bug happened only with news versions but if you want :

http://lists.debian.org/debian-security-announce/2008/msg00152.html

Wouter Horré (wouterh) said : #2

I know dapper isn't directly affected. But it is indirectly as users could have added vulnerable keys to their authorized_keys! Thanks for the pointer to dowkd.pl.

Wouter Horré (wouterh) said : #3

Thanks berg, that solved my question.