Connects to server of other computer, but rejects connections 12.10

Asked by Pablo on 2012-12-26

I am trying to connect between two computers with Ubuntu 12.10.

Starting on Computer A, from the Ubuntu "File" menu, I choose "Connect to Server...".

I fill out the proper server address, and choose the type as "SSH" from the selection list.

I connect fine to computer B.

But when I attempt the reverse and try to connect from computer B to computer A, I get a message that the server rejects the connection.

What do I need to do to correct this?

Thank you in advance for your help

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu openssh Edit question
Assignee:
No assignee Edit question
Solved by:
Pablo
Solved:
2012-12-27
Last query:
2012-12-27
Last reply:
2012-12-26
Thomas Krüger (thkrueger) said : #1

You might need to install an SSH server:

apt-get install openssh-server

Pablo (ceascolombia) said : #2

Thank you for your reply. There is something missing in what I did:

ceas@ceas-530U3C-530U4C:~$ apt-get install openssh-server
E: No se pudo abrir el archivo de bloqueo «/var/lib/dpkg/lock» - open (13: Permiso denegado)
E: Imposible bloquear el directorio de administración (/var/lib/dpkg/), ¿es superusuario?
ceas@ceas-530U3C-530U4C:~$

Basically the first line says that the file that blocks couldn't be opened and that permission was denied. The second line says that it was impossible to block the directory for administration and asks if I am a superuser.

What is the step I am missing?

Thank you

Pablo (ceascolombia) said : #3

My ignorance has been resolved. I realized I had to put sudo before the command you told me. Then your instructions worked and the problem is solved. Thank you.