package openssh-server 1:5.8p1-1ubuntu3 failed to install/upgrade: ErrorMessage: subprocess installed post-installation script returned error exit status 1

Asked by Jason Odoom on 2011-07-15

Encountered during Partial upgrade.

ProblemType: Package
DistroRelease: Ubuntu 11.04
Package: openssh-server 1:5.8p1-1ubuntu3
ProcVersionSignature: hostname 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Fri Jul 15 13:02:29 2011
ErrorMessage: ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
SSHDConfig: Error: command ['/usr/sbin/sshd', '-T'] failed with exit code 255: Privilege separation user sshd does not exist
SourcePackage: openssh
Title: package openssh-server 1:5.8p1-1ubuntu3 failed to install/upgrade: ErrorMessage: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to natty on 2011-07-15 (0 days ago)

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu openssh Edit question
Assignee:
No assignee Edit question
Last query:
2011-07-15
Last reply:
2011-07-15
Andreas Moog (ampelbein) said : #1

From the log:

Setting up libvirt-bin (0.8.8-1ubuntu6.2) ...
Adding group `libvirtd' (GID 132) ...
groupadd: cannot lock /etc/group; try again later.
addgroup: `/usr/sbin/groupadd -g 132 libvirtd' returned error code 10. Exiting.

Please remove /etc/group.lock and run:

'sudo dpkg --configure -a"

I suggest you log a bug

Can you help with this problem?

Provide an answer of your own, or ask Jason Odoom for more information if necessary.

To post a message you must log in.