How to overcome "tun0: Disabled Privacy Extensions"?

Asked by Uqbar on 2010-12-22

I need to open a tunnel between two machine of mine where I hold root access.
I've read this document: https://help.ubuntu.com/community/SSH_VPN .
I've set up a key pair between the two machine's root account (~root/.ssh), I've changed the sshd_config with the following
parameters:

PermitTunnel yes
PermitRootLogin without-password

while "PermitRootLogin yes" was already there.
I've then run the following command on one machine:

sudo ssh -NTCf -w 0:0

The ssh command goes background but no tun0 interface is created.
Moreover, the system log says: "tun0: Disabled Privacy Extensions"

How can I fix this thing?
Googling didn't provide any useful help so far.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu openssh Edit question
Assignee:
No assignee Edit question
Solved by:
Theodotos Andreou
Solved:
2010-12-22
Last query:
2010-12-22
Last reply:
2010-12-22
Best Theodotos Andreou (theodotos) said : #1

Try installing the uml-utilities and try again. In Terminal:

  sudo apt-get install uml-utilities

You can test if it works by creating a tun interface like this:

  tunctl -u $USER

Uqbar (uqbar) said : #2

That works as root.
But it creates tap0, not tun0!

Uqbar (uqbar) said : #3

It works!
Now the command "sudo ssh -NTCf -w 0:0" has created the local tun0 interface.
On the remote machine I can also see the tun0 interface.
So the point is that I was missing the uml-utilities.
You rock, Theodotos!
Ευχαριστώ σας!

Uqbar (uqbar) said : #4

Thanks Theodotos Andreou, that solved my question.

Theodotos Andreou (theodotos) said : #5

You really touch me with the Greek! You are most welcome.

I think we should add this information in the help page you reference above because it confuses people. I 'll try to contact the author.