unable to open remote java application over ssh (UGBoJ)

Asked by Titantux on 2010-11-11

Hello, thanks in advance & hope you are doing ok.

I'm trying to open a remote java application over ssh tunnel ie:

MiLap -> Aserver -> Bserver -RServer(Java application)

The tunnel is working normal, because I'm able to open simple xclock, xlogo, etc... the issue here is when I try it for java apps.
It really works with other distros confirmed (Slakware & Opensuse).
The only thing I got is the ugly gray box of java (UGBoJ) over new window.

What Ive done until now:

1. Using Live Ubntu... (UGBoJ)
2. I tried to copy same config from ssh_config & sshd_config from Opensuse.... (UGBoJ)
3. Locally I've change my java to Open & SUN java... (UGBoJ)
4. The only thing I've not is to change sun-java version to old one 1.6.20, on distro I used has 1.6.18 & 1.6.20, but I'm not able to find it to download... ???? (Sincerely I don't belive tha java version on my laptop is the error trigger, perhaps something configurable?)

What I've read it is following link:

http://www.javacoffeebreak.com/articles/greyboxapplets/index.html

Thanks,
Israel

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu openssh Edit question
Assignee:
No assignee Edit question
Last query:
2010-11-12
Last reply:
mycae (mycae) said : #1

Not sure, but sometimes if you
ssh -X user@host

this will not work, due to remote security settings.

You may need to

ssh -Y user@host.

There is more in the manpage about the difference between these two.

Titantux (israel-m-dj) said : #2

As well, had tried the one you said using "-Y" but is the same result ... UGBoJ

Titantux (israel-m-dj) said : #3

It seems it is something with new OpenSSH or OpenSSL version:

I've compared 10.04 against 10.10 and:
$ ssh -verison
10.10 OpenSSH_5.5p1 Debian-4ubuntu4 OpenSSL 0.9.8o 01 Jun 2010 ... UGBoJ
10.04 OpenSSH_5.3p1 Debian-3ubuntu4 OpenSSL 0.9.8o 25 Mar 2009 ... WORKING

I've compare ssh_config files & both versions are the same...

How can do more test, any ideas about it, what make different each version on it ?
Or what can I use to work within this version?
Regards,
Israel

Can you help with this problem?

Provide an answer of your own, or ask Titantux for more information if necessary.

To post a message you must log in.