blank line response to "echo $DISPLAY" - No remote X capability

Asked by Mark Garrow on 2010-08-29

This scenario is all on my local LAN. All machines are on the same subnet etc.. I ssh from my ubuntu gnome laptop to my kubuntu desktop using "ssh -X <name@IP Address>" .. after logging in I issue the command "echo $DISPLAY" and get a blank line as a response. I've checked /etc/ssh/sshd_config and /etc/ssh/ssh_config and changed the X11Forwarding no... to... X11forwarding yes. I've restarted ssh, tried logging out and back in, and rebooted the machine entirely with no response to the echo $DISPLAY command... This does work locally on the kubuntu machine however.

All this is to try getting remote X to work.

Any hints, tips, how-to's are welcome. If I've left anything out please let me know and I'll provide answers.

Thanks,
Mark / Scunizi

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu openssh Edit question
Assignee:
No assignee Edit question
Last query:
2010-09-03
Last reply:
2010-09-03

If you have access to the local machine test ssh's X forwarding locally.

   locally when i run "echo $DISPLAY" it returns: :0.0
   when i try to connect with "ssh localhost" and login when i run "echo $DISPLAY" it's blank
   when i try to connect with "ssh -X localhost" and login when i run "echo $DISPLAY" it returns: localhost:10.0

Something to test anyways, best of luck,
George

Mark Garrow (scunizi) said : #2

Thanks for your response George. Logging in using localhost has the same results... a blank line. If I'm at a simple CLI prompt (no ssh involved) the response to "echo $DISPLAY" is .... :0.0

Verify that sshd is forwarding X.

$ cat /etc/ssh/sshd_config | grep X
X11Forwarding yes
X11DisplayOffset 10

Good luck,
George

Mark Garrow (scunizi) said : #4

Thanks George.. I mentioned those settings in the original post.. I did verify them again and they are set correctly.

Well I'm fresh out of ideas. Hopefully someone else has some input. Best of luck,
George

Can you help with this problem?

Provide an answer of your own, or ask Mark Garrow for more information if necessary.

To post a message you must log in.