SSH Synchronization Server Name

Asked by SabreWolfy on 2010-08-28

On my server, sshd runs non-standard port YYY.

On my laptop, in /etc/hosts I have name "XXX" mapping to the LAN IP of my server. In SSH Synchronization Server name for Tomboy, is I fut in XXX:YYY and press "Save", it connects.

I have a dynamic DNS name for my server (AAA.BBB) with a free provider so that I can access it from the "outside". If I put AAA.BBB:YYY into the server box Tomboy cannot connect because of timeout. :( I can, however, SSH into AAA.BBB:YYY successfully, so the domain name DNS is working.

If I use the actual IP address the server has now (1.2.3.4) and port YYY to connect, then Tomboy connects.

So, it is only when I use the AAA.BBB name that it does not work, but that is the one I must use, because a local LAN IP or the actual IP the server has today is no good to use everyday from other locations outside the LAN.

Using Tomboy 1.2.1 on Lucid. Nothing in tomboy.log.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu openssh Edit question
Assignee:
No assignee Edit question
Solved by:
SabreWolfy
Solved:
2010-08-28
Last query:
2010-08-28
Last reply:
2010-08-28

You can show your internal name, it hides nothing. Your naming notation is incorrect to access your LAN PC. You need to forward port YYYY on your router to port YYYY on XXXX. I sugget you make XXXX a static IP so that DHCP doesn't break tings.

SabreWolfy (sabrewolfy) said : #2

SSH synchronization in Tomboy from a laptop on the LAN to the server (on the LAN) works via (1) the server's LAN dotted IP, (2) the server's LAN named IP and (3) the server's external IP.

It does NOT work when I use the server's "dyndns.org" domain name.

However, when I SSH into the server's dyndns,org domain name from the laptop, I am logged into the server. Therefore, the "dyndns.org" domain name and connection are working perfectly.

Ports are forwarded on the router already as the port I am using for Tomboy SSH is the port I have always used for SSH connections so it is already open on the router. The server has a static LAN IP but not a static external IP, as this is allocated "randomly" by my ISP; hence the "dyndns.org" name.

SabreWolfy (sabrewolfy) said : #3

To clarify: Laptop and server (called "defiant"; included in /etc/hosts) are on the LAN. Router port Y is open for SSH. Server running sshd listening on port Y, the port I always use for SSH.

On laptop on LAN, in Tomboy under SSH Synchronization I enter username and folder and address for server:

defiant:Y

and Tomboy connects. I enter:

192.168.1.105:Y [LAN address of server]

and Tomboy connects. I enter:

1.2.3.4:Y [external IP address from ISP]

and Tomboy connects. I enter:

AAA.dyndns.org

and Tomboy does *not* connect and says it times out. I enter:

$ ssh -p Y <email address hidden>

and I am logged directly into the server (no login required because of ssh keys).

Any ideas?

SabreWolfy (sabrewolfy) said : #4

I can't edit the previous message. Of course the last example was meant to be:

AAA.dyndns.org:Y

to include the port like all the other examples above.

SabreWolfy (sabrewolfy) said : #5

Renamed authorized_keys* from ~/.ssh on the server. Tried to "save" Tomboy SSH settings again. Got the same "timeout" message followed immediately by a dialog box asking for the password for <email address hidden>. I enter the correct password, the box goes away but it still does not connect. If I rename authorized_keys* back, the the timeout message appears as before, but not the "password" dialog. If there is something wrong with the keys, then how come I can SSH into the server without having to type a password?

SabreWolfy (sabrewolfy) said : #6

SOLVED.

In gconf-editor I found

sync_fuse_mount_timeout_ms

was set to 10000

I increased this to 50000 and the SSH connection to AAA.dyndns.org:Y worked.

Might be a good idea to add this setting to the UI.

Great share, hopefully this will help others too.

Glad you got the gold