default printer in OpenOffice

Asked by Blair Bowden

I would like to know how to change printers for Open Office 2.2-1,from default CUPS to a windows shared printer Canoni450.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu openoffice.org2 Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Richard Johnson (nixternal) said :
#1

Have you installed the printer correctly on your machine?

For instance with Kubuntu you would go "Kmenu > System Settings > Printers" and then add a printer and follow right along? If your Canon i450 was the default CUPs printer then it would be the default printer for oo2 also.

With Ubuntu you would go "System > Administration > Printing" and then double click the "New Printer" icon and follow the instructions.

Hope this helps, keep us informed. Thank you.

Revision history for this message
Blair Bowden (bolairo45) said :
#2

Hi Rich, the default printer for "OpenOffice" is "CUPS BJC-7000" and I
cannot see an option to change it, I have installed the printer as a
BJC-7000 (works my i450) locally and can print a test page no problems,
but when I try to print a document from "OpenOffice" nothing happens! No
job appears in the queue,
I can print from 'text editor' with out any problems, but I would like
to be able to print from "OpenOffice" as well.
I have also installed it as a "network printer" (home network with
Win2000 Pro and Unbutu) with the same results, I can print a test page
(from "Printer Properties") and print from "Text Editor" but not from
"OpenOffice".
I hope this information is of more help,
Thanking you,
Blair Bowden.

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
Rich Johnson
Sent: Wednesday, 14 June 2006 3:34 PM
To: <email address hidden>
Subject: [Support #1044]: Re: default printer in OpenOffice

Support request #1044 on Ubuntu changed:
https://launchpad.net/distros/ubuntu/+ticket/1044

Comment:
Have you installed the printer correctly on your machine?

For instance with Kubuntu you would go "Kmenu > System Settings >
Printers" and then add a printer and follow right along? If your Canon
i450 was the default CUPs printer then it would be the default printer
for oo2 also.

With Ubuntu you would go "System > Administration > Printing" and then
double click the "New Printer" icon and follow the instructions.

Hope this helps, keep us informed. Thank you.

--
No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.1.394 / Virus Database: 268.8.4/363 - Release Date:
13/06/2006

--
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.394 / Virus Database: 268.8.4/363 - Release Date: 13/06/2006

Revision history for this message
Richard Johnson (nixternal) said :
#3

Hey Blair,

Even though the printer you want to is a "Windows Shared Printer", you still need to install it into Cups. I don't know if I am reading the issues correctly. Your original question is "I would like to know how to change printers for Open Office 2.2-1,from default CUPS to a windows shared printer Canoni450. In order to change it in Opern Office it needs to be installed in the print services for the system. YOu say you have installed the printer and can print a test page and print from a text editor, but you can't print from Open Office. If it is installed, and you can select the printer in Open Office and it still won't print, you can try to change postscript settings in teh printing preferences in Open Office (File Menu > Print Settings > "Select the Printer" > Properties > Device Tab > PostScript Level), change it from "From Driver" to "1", or "2", and see if this helps. Keep me informed. Thanks Blair.

Revision history for this message
Blair Bowden (bolairo45) said :
#4

Hi Rich, a big THANK YOU, the printer is now working perfectly :-)
simple when you know how, again - thank you.
Regards,
Blair Bowden.

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
Rich Johnson
Sent: Thursday, 15 June 2006 10:19 AM
To: <email address hidden>
Subject: [Support #1044]: RE: [Support #1044]: Re: default printer
inOpenOffice

Support request #1044 on Ubuntu changed:
https://launchpad.net/distros/ubuntu/+ticket/1044

Comment:
Hey Blair,

Even though the printer you want to is a "Windows Shared Printer", you
still need to install it into Cups. I don't know if I am reading the
issues correctly. Your original question is "I would like to know how to
change printers for Open Office 2.2-1,from default CUPS to a windows
shared printer Canoni450. In order to change it in Opern Office it needs
to be installed in the print services for the system. YOu say you have
installed the printer and can print a test page and print from a text
editor, but you can't print from Open Office. If it is installed, and
you can select the printer in Open Office and it still won't print, you
can try to change postscript settings in teh printing preferences in
Open Office (File Menu > Print Settings > "Select the Printer" >
Properties > Device Tab > PostScript Level), change it from "From
Driver" to "1", or "2", and see if this helps. Keep me informed. Thanks
Blair.

--
No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.1.394 / Virus Database: 268.8.4/364 - Release Date:
14/06/2006

--
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.394 / Virus Database: 268.8.4/364 - Release Date: 14/06/2006

Revision history for this message
Richard Johnson (nixternal) said :
#5

On Wednesday 14 June 2006 21:06, Blair Bowden wrote:
> Hi Rich, a big THANK YOU, the printer is now working perfectly :-)
> simple when you know how, again - thank you.
> Regards,
> Blair Bowden.
Blair,

Great, I am glad you got it fixed. I was a little confused, that is why I
added all the information in my previous message. So what was the fix? Thanks
Blair, and good luck with your Ubuntu future!!!
--
Rich Johnson (nixternal)
"The best thing about democracy is that it gives every voter a chance to do
something stupid."

Revision history for this message
Blair Bowden (bolairo45) said :
#6

Hi Rich, the tick was in "Open Office (File Menu > Print Settings >
"Select the Printer" > Properties > Device Tab > PostScript Level),
change it from "From Driver" to "1", or "2","
I changed it to "1" no problems now, unless I am trying to print in
OpenOffice from a shared folder from my windows computer, but if I save
the .doc to my Unbutu machine I can then print it OK, must be something
to do with user privileges, but I hope to figure that out soon.
Thanx,
Blair Bowden.
-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
Rich Johnson
Sent: Thursday, 15 June 2006 12:51 PM
To: <email address hidden>
Subject: [Support #1044]: Re: [Support #1044]: RE: [Support #1044]:
RE:[Support #1044]: Re: default printer inOpenOffice

Support request #1044 on Ubuntu changed:
https://launchpad.net/distros/ubuntu/+ticket/1044

Comment:
On Wednesday 14 June 2006 21:06, Blair Bowden wrote:
> Hi Rich, a big THANK YOU, the printer is now working perfectly :-)
> simple when you know how, again - thank you.
> Regards,
> Blair Bowden.
Blair,

Great, I am glad you got it fixed. I was a little confused, that is why
I
added all the information in my previous message. So what was the fix?
Thanks
Blair, and good luck with your Ubuntu future!!!
--
Rich Johnson (nixternal)
"The best thing about democracy is that it gives every voter a chance to
do
something stupid."

--
No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.1.394 / Virus Database: 268.8.4/364 - Release Date:
14/06/2006

--
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.394 / Virus Database: 268.8.4/364 - Release Date: 14/06/2006

Revision history for this message
Blair Bowden (bolairo45) said :
#7

Hi again Rich, another question for you, I am running out of room on my
hard drive and have installed another hard drive with no problems, but I
would like to know how to change the default download folder for
'updates' to this drive so I can download and install "New Distribution
Release 6.06 LTS"
Thanx,
Blair Bowden

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
Rich Johnson
Sent: Thursday, 15 June 2006 12:51 PM
To: <email address hidden>
Subject: [Support #1044]: Re: [Support #1044]: RE: [Support #1044]:
RE:[Support #1044]: Re: default printer inOpenOffice

Support request #1044 on Ubuntu changed:
https://launchpad.net/distros/ubuntu/+ticket/1044

Comment:
On Wednesday 14 June 2006 21:06, Blair Bowden wrote:
> Hi Rich, a big THANK YOU, the printer is now working perfectly :-)
> simple when you know how, again - thank you.
> Regards,
> Blair Bowden.
Blair,

Great, I am glad you got it fixed. I was a little confused, that is why
I
added all the information in my previous message. So what was the fix?
Thanks
Blair, and good luck with your Ubuntu future!!!
--
Rich Johnson (nixternal)
"The best thing about democracy is that it gives every voter a chance to
do
something stupid."

--
No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.1.394 / Virus Database: 268.8.4/364 - Release Date:
14/06/2006

--
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.394 / Virus Database: 268.8.4/364 - Release Date: 14/06/2006

Can you help with this problem?

Provide an answer of your own, or ask Blair Bowden for more information if necessary.

To post a message you must log in.