How do I get spellcheck to work for Canadian English?

Asked by mina299 on 2009-11-11

I have gone through the other spellcheck topics in this site and found my answer: the spellcheck does not work for certain regions for English. Thus I discovered that mine only worked when I switched my region from English (USA) to English (Canada) in Tools>Options>Languages for the user interface option.

My question is, is there a way to get the Canadian English spellcheck working? Is there something I can download? Or is this just wishful thinking? It seems to me that if the option exists, then the spellcheck should work! That's just my crazy reasoning, though. Maybe only the most popular languages are meant to work on this thing. I feel I have no right to complain since it's freeware.

I'm using OO 3.0.1
OS is Ubuntu 9.0.4

Thank you for any help, and if it has been solved in a previous topic and I missed it, please feel free to reference it here. Any help is greatly appreciated!

-Mina

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu openoffice.org Edit question
Assignee:
No assignee Edit question
Solved by:
mina299
Solved:
2009-11-11
Last query:
2009-11-11
Last reply:
2009-11-11
Nigel Babu (nigelbabu) said : #1

Hi Mina

Open Office does not give you Canadian spell check by default. You can download the Canadian dictionary extension from here

http://extensions.services.openoffice.org/project/en_CA

For instructions on installing it, please see here:

http://extensions.services.openoffice.org/resources/user/howto_install

mina299 (lady-mina-silverstar) said : #2

Thank you for the response. I'm sure this would have solved my problem; maybe I'm too used to Windows to understand how to install these things. I keep thinking there's some kind of "program files" solution to this problem. I don't know where to save my extensions.

Here's what happened: I clicked on the link to download the extension, and it asked me if I wanted to open it with OO. I did. Then the Extension Manager came up and asked me to add it. I clicked on "add". Then a window called "add extensions" popped up and listed all of my files. I'm obviously supposed to choose one. I searched through other forums but nobody was being specific as to what this process actually is. They're all so technical, and I'm new to the Ubuntu scene.

I gave up searching for a folder. I found many OO folders after getting it to search for me, but they all seem to be in different locations. So which one is it? Confused, I gave up and just made a folder in "Documents" called "Extensions" since I am apparently not allowed to create a folder in the system files. But after that, nothing happens. The only options from there are "cancel" and "open."

Can you please give me additional guidance? The instructions were only in three parts and did not explain how to use the extension manager past the point of clicking "add."

Thank you for any additional help!
~Mina

mina299 (lady-mina-silverstar) said : #3

All right, I managed to solve the problem using common sense. I guess I'm a little slow today.

Thanks for your help!

I solved the problem by going back to the link to download the extension file. Instead of using "open with" I used "save file" which automatically saved to my desktop. I then cut and pasted that file from my desktop to that folder I created (Documents>Extensions) and then went to OO and opened extension manager and followed the same routine, finally opening an actual file. Not a folder in which to save a file. Duh! One could just facedesk.

Thanks again for your help, Nigel!