OpenOffice Presentation and PowerPoint Import

Asked by Richard A Bevis

After recent Update Manager update of several OpenOffice packages, PowerPoint imports load, show on sceen for a second or two, then the screen goes blank. Specifically, when I click on a PowerPoint attachment in an Evolution email, then click on "Open in OOo Presentation," the splash screen flashes, the loading bar fills across the bottom of the screen, the imported presentation shows for a couple seconds, then the whole screen goes blank. This never happened before the recent update although I was running OOo 3.1 after going through "Ubuntu Tweak" to upgrade from 3.0. Is this a bug? Or something to take up with the Sun Micro people? As always, any help is greatly appreciated. Oh yes, OS is Jaunty. Thanks.


Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Richard A Bevis
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :


mv ~/ ~/.openoffice.org_old

then rerun the app

Revision history for this message
Richard A Bevis (ra-bevis) said :

Tried that. Now the screen fades about half way after a couple seconds. I can see the presentation through the fog, but can't do anything with it.

Revision history for this message
jtniehof (jtniehof) said :

Kinda crazy, but try turning off desktop effects? System, preferences, appearance, visual effects tab, click on "None." It sounds like it might be dimming your presentation as a "background" window.

Does this happen with other presentations? (stuff opened from places other than your email, OO presentations instead of PP, etc.)

Revision history for this message
Richard A Bevis (ra-bevis) said :

I tried both of these solutions. The best I can get is that the presentation loads and starts with the first slide appearing brightly, but then hangs up without advancing to the next slide. This with visual effects in any position. Before update, Impress didn't automatically go into slide show mode, I could click the slide I wanted to view from the left side bar, now it goes right into the slide show with the afore mentioned results, except that I notice in the second or two before this happens that all the slides in the preview bar are blank but the first one which the program hangs up on. I'm not finding where I can select an option for the slide show not to automatically start. I don't know what would happen with other presentations, as PP email attachments from a Windows friend are the only presentations I open with Impress. I'm wondering if it would work if I saved the file and converted it to OOo format before opening it, but I haven't figured out how to do that yet. Thanks.


Revision history for this message
Carlos Joel Delgado Pizarro (c0x6a) said :

Try this one, open a new OOo document (Impress, Wirter or Calc, doesn't matter) and go to menu Tools -> Options you will be shown a window, look for -> View and uncheck (if is checked) the option that says "Use hardware acceleration" or something with OpenGL (I don't have OOo in English right now) in the Graphics output area (up-right)
then close OOo completely and try to open your presentation again.

Revision history for this message
Richard A Bevis (ra-bevis) said :

Thanks everyone for all your help. Carlos, I tried your suggestion alone and in combination with jt's to no avail. Finally, I uninstalled the whole OOo kit and kabudle, restored my settings and now the darn thing works!?! I have no explanation, but consider myself blessed by the African Gods and the Ubuntu community. Again thanks.


Revision history for this message
ub20073 (andresfeal) said :

No puedo ver las presentaciones de Powerpoin , alguien puede decirme como puedo verlas uso Openoffice