How to import Greek and Hebrew words in OpenOffice

Asked by Piet van der Lugt on 2009-03-26

I work with BibleWorks 6 and want to import Greek and Hebrew words into OpenOffice. When I copy there the words are imported but not in Hebrew or Greek fonts. Bibleworks works under Vine. I installed via Synaptic all possible Greek and Hebrew fonts but no success. Who can help me?
Best regards
Piet van der Lugt

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu openoffice.org Edit question
Assignee:
No assignee Edit question
Solved by:
Abi ^-^
Solved:
2009-03-30
Last query:
2009-03-30
Last reply:
2009-03-30
Abi ^-^ (abiyasa-eka) said : #1

Hello, did you mean import ttf file to open office? have you downlod the ttf files?

Thank you

Abi ^-^ (abiyasa-eka) said : #2

Hello, did you mean import ttf file to open office? have you downlod the ttf files?

Thank you

Abi ^-^ schreef:
> Your question #65474 on openoffice.org in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/openoffice.org/+question/65474
>
> Abi ^-^ requested for more information:
> Hello, did you mean import ttf file to open office? have you downlod the
> ttf files?
>
>
> Thank you
>
>
Dear Abi,

Thanks for your reaction.
I downloaded and imported ttf fonts via Wine-Doors and that was
neccessary to work with BibleWorks layout, but it is not the solution
for my present problem. When I am working in Bibleworks I like to copy
Hebrew or Greek words to OpenOffice but when the words are copied to
Hebrew or Greek characters are shown. In the list of fonts in OpenOffice
there are no Hebrew or Greek fonts and I suppose that is the point.
Question is how to I get the there>
Awaiting your reply.

Beste regards,

Piet

Abi ^-^ (abiyasa-eka) said : #4

Hello, please open nautilus as root first

press alt+F2

type gksu nautilus /usr/share/fonts/truetype

make your new folder, copy ttf file into folder

open terminal (Aplication - Accesories - Terminal

type

sudo fc-cache -f -v

And try open openoffice, there should be Hebrew or Greek fonts ...

Good luck

Abi ^-^ schreef:
> Your question #65474 on openoffice.org in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/openoffice.org/+question/65474
>
> Status: Open => Answered
>
> Abi ^-^ proposed the following answer:
> Hello, please open nautilus as root first
>
> press alt+F2
>
> type gksu nautilus /usr/share/fonts/truetype
>
> make your new folder, copy ttf file into folder
>
> open terminal (Aplication - Accesories - Terminal
>
> type
>
> sudo fc-cache -f -v
>
> And try open openoffice, there should be Hebrew or Greek fonts ...
>
>
> Good luck
>
>
Dear Abi,

Thanks for your help.
I tried two times but no success. Maybe I did it wrong as I do not
really understand make your new folder. I selected an excisting folder
and copied the fonts there but no result.
So plse explain somewhat clearer what you mean there.

Thanks a lot.

Piet

peter (peter-neuweiler) said : #6

I guess you should define the two languages Greek and Hebrews in the OO application. If you have OO 3.0, have a look at Tools > Options > Language Settings. There you can define the languages.

Hope it helps.
Peter

Abi ^-^ (abiyasa-eka) said : #7

In my experience, when i want to add some others font, like Mac os fonts,
i always use nautilus as root to copy the font into folder truetype, open terminal, and do sudo fc-cache -f -v (with sudo)

and it always work and show in open office ....

Try what peter suggest first

Abi ^-^ schreef:
> Your question #65474 on openoffice.org in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/openoffice.org/+question/65474
>
> Abi ^-^ proposed the following answer:
> In my experience, when i want to add some others font, like Mac os fonts,
> i always use nautilus as root to copy the font into folder truetype, open terminal, and do sudo fc-cache -f -v (with sudo)
>
> and it always work and show in open office ....
>
> Try what peter suggest first
>
>
Dear Abi,

Thanks for your help. It took some effort much it works now.

Best regards,

Piet

peter schreef:
> Your question #65474 on openoffice.org in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/openoffice.org/+question/65474
>
> Status: Open => Answered
>
> peter proposed the following answer:
> I guess you should define the two languages Greek and Hebrews in the OO
> application. If you have OO 3.0, have a look at Tools > Options >
> Language Settings. There you can define the languages.
>
> Hope it helps.
> Peter
>
>
Dear Peter,

Thanks for your help but I tried it already. Abi gave me the right
method and it works now so thanks very much as well for your reaction.

Beste regards,

Piet

Best Abi ^-^ (abiyasa-eka) said : #10

Hello, please close this question if your problem is solved ....

Good Luck ^-^

Problem was solved after downloading BWfonts Greek and Hebrew and installing them as you advised.
Thanks a lot