How to change spelling language in OO

Asked by Bogdan Butnaru on 2007-04-05

Hi! I'm using OpenOffice (2.2.0-0ubuntu2) on Ubuntu Feisty.

I frequently need to edit documents in either French or English, which were originally created using PowerPoint or Word. However, I can't figure out how to change the language used for spell-checking. OO always seems to do the spell checking in the language the document was created in (if I create them, then it's English, if they're created by others in Word or PowerPoint, French -- but that's because they use French all the time). Sometimes I need to take a document created in one of the languages and change at least parts of it to the other, but I can't figure out how.

The obvious thing would be to select the text to change, go to Tools > Language, and pick another language like Word does. But I don't have any such option in OO, it only shows "Thesaurus" and "Hyphenation" there. If I start a spell-check, there is a little drop-down box with the language; I can select the other dictionary there, but it reverts to the one it uses by default.

What can I do?

(BTW, I'm quite sure I have the necessary dictionaries installed, since it _can_ spell-check in both languages, correctly. I just can't pick the language in a sane way.)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu openoffice.org Edit question
Assignee:
No assignee Edit question
Solved by:
Carles Oriol
Solved:
2007-04-05
Last query:
2007-04-05
Last reply:
2007-04-05

You need to go to Tools > Options > Language preferences > Language. Then choose a default language for all documents.

It worked for me, but be aware that this changes the default language for ALL documents and not the current one.

Bogdan Butnaru (bogdanb) said : #2

Yes, that would change the default language. It can also change the default language for a single document, I think, since it has a little checkbox near the language drop-box.

However I need to change the spelling language for text already existing in the document (i.e., mis-labeled), not the default language.

Best Carles Oriol (carlesoriol) said : #3

Select text -> Format -> Character -> Select lenguage.

Bogdan Butnaru (bogdanb) said : #4

Thanks a lot! I wouldn't have looked there in a hundred years...

Thanks, Carles. I could never find that, and I do really appreciate that feature!

Dick Kniep (dick-kniep) said : #6

I think this feature should be in the spellcheck item, instead of here. Thanks anyway for this information, and like Charles said, I would never have found this.....

Peter Kornerup (kornerup) said : #7

The default language in my system is set to Danish, but I also have dictionaries for UK and USA English. However, which way I try to change the default language to any of the two versions of English, the spell checker reverts to Danish. I have tried in vain all the above suggestions, but nothing seems to work. As a last resort I have tried, but I cannot find a way of deleting the dictionary for Danish.

Me too. I'm english but need to work in both languages. The stuff that came with ubuntu 10-4 does not seem to be as good as 9-4. Tool/language click french for all the doc and spelling in word processor is still english. Top of spell check box I can select french ONE WORD AT A TIME. This should really stay changed till the next time I hack it or get a new doc. Ian.