Change default font to Times New Roman 12

Asked by Donna Simonds on 2007-12-31

Have changed from laptop to desktop, still using OOWriter 2.3 but unable on this
edition to get default font: Times changed over to Times New Roman. Did not see
it listed in the fonts under Options menu-->oowriter.
In checking the package manager for msttcorefonts: it states there is an OOWriter
pkg listed.

Summary of question: I need to get TNR or Times New Roman as the default font.

Thank you, Donna Simonds

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu openoffice.org Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
2008-01-04
Last query:
2008-01-04
Last reply:
2008-01-04

Please try to install msttcorefonts

Open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo aptitude update
sudo aptitude install msttcorefonts

give your user password when requested, you don't see nothing when you type it, then press enter.

Hope this helps

Donna Simonds (dmsimonds) said : #2

Sorry, this fix made things worse. Can't get even Times now.

Here is our challenge:
What we need here is TNR or Times New Roman to be Default setting for fonts.
Our focus is and has been until now, make OOWriter work better than MSWord
and you will have a preferred product over Microsoft.
To do this we need the publishing standard in fonts.

Donna Simonds

Donna Simonds (dmsimonds) said : #3

You may be interested to know that the msttcorefonts are available on the
Synaptic Package Manager for Mepis and not Ubuntu/Kubuntu.
I got it to install with OOWriter and works fine.

Any reason for this?

Donna Simonds

You will need an Internet connection to download these fonts if you don't
already have them.
You have also to enable the multiverse repository.

Using Synaptic please first enable the multiverse repository:

Launch Synaptic from menu: System->Administration->Synaptic package manager
From Synaptic menu: Settings->Repositories-> Tab Ubuntu software
enable "Software restricted by copyright or legal issue (multiverse)"
Close Synaptic

Then open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo aptitude update
sudo aptitude install msttcorefonts

give your user password when requested, you don't see nothing when you type it, then press enter.

Thank you

Donna Simonds (dmsimonds) said : #5

Marcoba: Looks like the last step in our process didn't work and to make OOWriter
the word processor of choice for those of us working in the MSfont dependent
publishing world, I will stay available to help solve and test the issue.
Below was the last point in your instructions.

sudo aptitude install msttcorefonts
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
The following packages are BROKEN:
  msttcorefonts
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 33.2kB of archives. After unpacking 193kB will be used.
The following packages have unmet dependencies:
  msttcorefonts: Depends: cabextract which is a virtual package.
Resolving dependencies...
Unable to resolve dependencies! Giving up...
Abort.

Donna Simonds
<email address hidden>
Linux Rules

Donna Simonds (dmsimonds) said : #6

Marcoba:
I went back into Synaptic, updated all OpenOffice packages and then the
msttcorefonts selection comes up as a normal check box, but also got
this when trying to install the package.

msttcorefonts:
 Depends: cabextract but it is not installable

I hope this helps in trying to solve our puzzle.

Donna Simonds

Open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo aptitude update
sudo aptitude install cabextract
sudo aptitude install msttcorefonts

give your user password when requested, you don't see nothing when you type it, then press enter.

Hope this helps

Donna Simonds (dmsimonds) said : #8

Still unable to resolve unmet dependencies.

Donna Simonds (dmsimonds) said : #9

Yes, still open.
Anyone out here want take this issue on?
I am using OOWriter in Mepis until Ubuntu can resolve the issue.

Donna Simonds
Life is a challenge, grab it.

Using Synaptic please first enable all the repositories:

Launch Synaptic from menu: System->Administration->Synaptic package manager
From Synaptic menu: Settings->Repositories-> Tab Ubuntu software
enable all the repositories
Close Synaptic

Then open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo aptitude update
sudo aptitude install cabextract
sudo aptitude install msttcorefonts

give your user password when requested, you don't see nothing when you type it, then press enter.

Hope this helps

Donna Simonds (dmsimonds) said : #11

Congrats Marcoba.
msttcorefonts is now installed for OOWriter.
Another reason why I only use Linux.

Donna Simonds