can't change delimiter when a file is already saved as csv

Asked by Alistair Buxton on 2012-04-26

scenario:

You want to save a spreadsheet as CSV so you can quickly do some bulk transformations on it with a script file. You save it as a csv file using | as a delimiter. You then discover that the file uses | in other places, so you decide to use a different delimeter. You do file->save as and save as CSV again, but open office does not present the dialogue to configure output format now.

to reproduce:

1. make a new spreadsheet.
2. save as csv. a dialogue appears to configure the delimiter etc.
3. save as csv again. the dialogue is not displayed.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: openoffice.org-calc (not installed)
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu5
Architecture: amd64
Date: Thu Apr 26 04:12:06 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: openoffice.org
UpgradeStatus: No upgrade log present (probably fresh install)
---
ApportVersion: 2.0.1-0ubuntu5
Architecture: amd64
DistroRelease: Ubuntu 12.04
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
NonfreeKernelModules: nvidia
Package: libreoffice-calc 1:3.5.2-2ubuntu1
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Tags: precise
Uname: Linux 3.2.0-23-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dialout dip lp lpadmin plugdev sambashare sudo vboxusers

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu openoffice.org Edit question
Assignee:
No assignee Edit question
Solved by:
Björn Michaelsen
Solved:
2012-04-27
Last query:
2012-04-27
Last reply:
2012-04-27

User didnt find available feature

Check the "Edit Filter Settings" box in the save dialog

Alistair Buxton (a-j-buxton) said : #3

Thanks Björn Michaelsen, that solved my question.