OpenOffice Calc-freezes when online bank data copy

Asked by Peter Saxon on 2012-02-24

Using KDE Desktop & Firefox: when attempting to copy bank online data to spreadsheet. spreadsheet freezes.
It unfreezes on closing bank web page. Am able to copy/paste into OpenOffice-Word.
Previously it worked fine on the Gnome desktop.
Any suggestions would be appreciated.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu openoffice.org Edit question
Assignee:
No assignee Edit question
Solved by:
mycae
Solved:
2012-02-25
Last query:
2012-02-25
Last reply:
2012-02-25

Are there any bugs reported?

Peter Saxon (bumpysax) said : #2

No bugs reported!

mycae (mycae) said : #3

As a work around, try pasting into a text editor, such as gedit, first. This will destroy any formatting (fonts etc), but usually preserves table layouts.

mycae (mycae) said : #4

Ok, quick question, does your CPU usage go up? Do you see if any single program is hogging the CPU?

Peter Saxon (bumpysax) said : #5

The workaround is more messy as I lose the formatting - could use it in an emergency, but prefer copy-paste method. Less mistakes!
Re cpu - When OpenOffice runs, it fluctuates 65 -100 for 10-15 secs->back to 65%
Same freezeup occurs while Bank web page is open. As soon as I close it, cpu ->100% for 20 secs ->65%.
OpenOffice is immediately usable.
On closing, a message was on the desktop:
System Notification Helper:
Extra plugins available. Clicked OK, nothing happens.

Best mycae (mycae) said : #6

Hi Peter,

If it is openoffice using the CPU, you could try disabling the java runtime in openoffice. Sometimes extensions to openoffice can cause problems, such as a non-responsive user interface.

Tools->Options->Java-> uncheck "Use a java runtime environment".

I don't know what is causing the spin (non-responsive program), but it this is a shot in the dark that may help.

Peter Saxon (bumpysax) said : #7

Disabling the java runtime made no difference.
HOWEVER - I discovered what is causing the problem!!
I had a copy of the Bank URL on my spreadsheet - I removed it, then logged onto my bank using a Bookmark, now I am back to normal!!
Thanks for your interest & assistance mycae- it was much appreciated!